Atom constantly forgets last project when re-opened


#1

Using Atom 1.15.0 on iMac 27" running macOS Sierra 10.12.3.

I’ve finally gotten frustrated enough by this behavior to dedicate some time to trying to report it.

I know this topic is similar to at least 4 other topics, but it seems this is a long-festering problem which the development team is either not interested in fixing, or doesn’t realize this remains broken.

90% (not 100% - wtf?) of the time, when I close and re-open Atom, it doesn’t remember my last project. In addition, the list under File > Reopen Project is empty, and using File > Reopen last item doesn’t work either. I can find no rhyme or reason as to why this rarely works, but mostly doesn’t.

I have read through and followed the advice on all of the similar topics to no avail (i.e. Open Empty Editor on Start unchecked, permissions on ~/.atom/storage/application.json correct, I’ve tried deleting that file - it’s always empty) - Atom just constantly doesn’t save my project history, and nearly every time I open it, I have to perform: File > Add Project Folder… and re-add my project before I start working.

I have placed the Atom icon in my MaxOS Dock, and usually double-click it to open. With every other application I normally use on a Mac (or Windows) - for years now - using this method works the way I expect: either the tabs open when I closed the program are restored, or - at a minimum - I have a list of prior documents or folders, which I can use with File > Open Recent Document.

None of these common methods work with Atom. I LOVE Atom! This is an amazing product! So it drives me crazy that this common, standard behavior doesn’t work. This has obviously been an issue for many people, so I don’t understand how this issue remains unfixed despite being reported by many over the years.

I’m a long-term DevOps and AWS architect. I know how to use software tools. If someone comes back and tells me I’m not closing or using Atom right, my response is that this isn’t rocket science. I should be able to close the tool with command-Q, and when I reopen it, have my last project shown, see my last project in the list which - seriously - is named “Reopen Project” - REGARDLESS of how I do this. It’s basic functionality. Why this doesn’t work, and hasn’t been fixed after so many people are having a problem with is, is astonishing!

Please fix this so it works.


#2

Thanks for reporting the problem and being so detailed in what you’ve tried :heart_eyes: There are definitely still bugs around these workflows. We do care and are attempting to fix the problems that we can nail down repro steps for. The detail you’ve given is a big help for that!

Besides the things you’ve mentioned trying, Atom uses IndexedDb to store project state. This is stored, on macOS, in ~/Library/Application Support/Atom/IndexedDB. Have you checked the permissions there? (It might be good to double-check the permissions in ~/Library/Application Support/Atom as a whole.)

Additionally, you mention that you checked the permissions on ~/.atom/storage/application.json but not ~/.atom/storage or ~/.atom. Have you followed the steps in the Debugging section of the Atom Flight Manual? Specifically the section on resetting Atom to factory defaults? If there is a deeper permissions problem there, that should resolve it.

The problem is that it isn’t an issue but many issues that seem to have the same symptoms because of the paucity of detail that people typically give when reporting the problem. Thanks for reaching out to work with us so we can help get this fixed for you :grinning:


#3

Thanks for being so willing to work with me to fix this - very - irritating problem. And for being responsive.

Have some long meetings soon, but could work on this to check what you asked later today, and will report back.


#4

You’re welcome :grinning: I’m glad I can help.

To give a little more background, the reason why I suspect this is a permissions problem is that the flow you seem to be describing is the standard one and you mention that ~/.atom/storage/application.json is always empty.


#5

I just want to chime in that I have the same problem, or, as it where, a problem that leads to the same symptoms: I have had a project list like once or twice, but it is generally empty. Atom always opens an empty editor on start, though “Open Empty Editor On Start” is unchecked, and “Restore Previous Windows On Start” is checked. “Reopen last item” has no result. My ~/.atom/storage/application.json contains one line: [{"initialPaths":["/Users/michael/.atom/storage"]}].

My Atom version is 1.15.0, my OS is MacOS 10.12.4.

Let me know if you need any more information.


#6

Is this the right place to report this problem (and to get a response?). Or should I open an issue on Atom?


#7

A GitHub issue is generally more addressable for the devs.


Atom won't save my default file tree
#8

Right, I’ll open one.