Atom completely died on my ubuntu 17.10


#1

Hi,

I was using atom for about an half year without any problems, but yesterday it crashed the first time
for some reason. If I now try to open it again nothing happens.
I also tried “atom --safe” via command line. That did not help. I found out that the atom command itself is completely dead. The command does nothing anymore. I can use the atom command with all parameters, even non existing ones and I get the new command line instantly. So it looks like the command does nothing anymore. I also tried do remove atom and deleting the .atom folder at my home directory with no success.


#2

Hi,

The Atom flight-manual has a couple of things you can try to resolve issues like this: http://flight-manual.atom.io/hacking-atom/sections/debugging/#debugging

Some suggestions:

  • atom --help do you get any output?
  • atom --clear-window-state does Atom start again? (Note that this command will destroy any unsaved changes you might have across all projects)
  • atom --foreground is there any error message logged to the terminal?

#3

I already saw the debugging section and tried some things, but I never get output, error message and not even a delay between the commands.


#4

The .atom folder doesn’t have anything to do with the atom command. When you tried to remove Atom, what steps did you take?


#5

I opend the Ubuntu Software Application, clicked on “Installed” Tab and then on “Remove” at the Atom Entry.
After a Laptop restart I installed Atom again via the Ubuntu Software Application.


#6

It’s possible that the command itself broke, and then removing Atom didn’t uninstall the command so it didn’t get fixed when you reinstalled. I don’t have a system that I can check on at the moment, but which atom should indicate to you the location of the command file and, if my hypothesis is correct, could still print out a result after uninstalling it. You could also try downloading and installing it manually.


#7

If I remove Atom I get the error, that the command “atom” is not known. So it looks like Atom is uninstalled.
After installing Atom again “which atom” prints the default path: “/snap/bin/atom”.


#8

Looks like you installed Atom as a snap. We don’t support the Atom snap package so I recommend that you uninstall it and install either the .deb from https://atom.io or use the official package repository.


#9

After restinstalling atom with the official package repo it works again.
Thank you