Atom . command does not open current directory


#1

OS: Winodws 7 64 bit
Atom Version - 1.23.1

on command line entering atom . does not open the atom in the current directory.
Directory i see is C:\Users\XXXXXX\AppData\Local\atom\app-1.23.1

This behaves as this is the default atom folder which will open no matter i type atom . from any directory.

What might be causing this issue? I observed developer tools and i do not see any error but one warning as below

IntersectionObserver.observe(target): target element is not a descendant of root.
TreeView @ <embedded>:122211

#2

If you run atom --safe . does that work?

Also, if you run atom directoryName (where directoryName is the name of some project directory you want to open in Atom), does that work?

Lastly, can you share a GIF/screencast that shows this behavior all the way from the first step where you run atom .?


#3

Hi rsese

I have the same issue as just10minutes. If I run atom --safe . I get the same result. Running atom "C:\full\directory\path" I get the expected result of atom opening that folder. Lastly I’m not sure what you mean by running atom directoryName. Is directoryName the name of the folder I want to open, or do I have to have saved it as a project at some point.

Any recommendations would be very helpful as I haven’t been able to find any other people with the same problem.

Thanks.


#4

Atom has no ability to save projects without using a package. directoryName is a directory inside your current directory that you are telling Atom to open (as opposed to ., which resolves to the current directory).