Atom can't start up, even with --safe


#1

On opening Atom, the window opens behind all other windows and doesn’t show up in the app switcher (cmd + tab). On bringing Atom into focus, it doesn’t have a menu bar (continues to be set for chrome or terminal or whatever the last focused application was). When Atom is in focus, doesn’t respond to any keyboard input, otherwise I can click around.

Removing my ~/.atom directory or starting with atom --safe does not help. Deleting /Applications/Atom/ and re-downloading from https://atom.io doesn’t help either.

$ apm --version
apm  1.1.1
npm  2.13.3
node 0.10.40
python 2.7.10
git 2.5.1

$ atom --version
1.1.0

$ apm list
Built-in Atom packages (90)
├── about@1.1.0
├── archive-view@0.61.0
├── atom-dark-syntax@0.27.0
├── atom-dark-ui@0.51.0
├── atom-light-syntax@0.28.0
├── atom-light-ui@0.43.0
├── autocomplete-atom-api@0.9.2
├── autocomplete-css@0.11.0
├── autocomplete-html@0.7.2
├── autocomplete-plus@2.22.0
├── autocomplete-snippets@1.7.1
├── autoflow@0.26.0
├── autosave@0.22.0
├── background-tips@0.26.0
├── base16-tomorrow-dark-theme@1.0.0
├── base16-tomorrow-light-theme@1.0.0
├── bookmarks@0.38.0
├── bracket-matcher@0.78.0
├── command-palette@0.36.0
├── deprecation-cop@0.54.0
├── dev-live-reload@0.47.0
├── encoding-selector@0.21.0
├── exception-reporting@0.37.0
├── find-and-replace@0.185.0
├── fuzzy-finder@0.90.0
├── git-diff@0.56.0
├── go-to-line@0.30.0
├── grammar-selector@0.47.0
├── image-view@0.55.0
├── incompatible-packages@0.25.0
├── keybinding-resolver@0.33.0
├── language-c@0.48.0
├── language-clojure@0.18.0
├── language-coffee-script@0.42.0
├── language-csharp@0.11.0
├── language-css@0.34.0
├── language-gfm@0.81.0
├── language-git@0.10.0
├── language-go@0.39.0
├── language-html@0.42.0
├── language-hyperlink@0.14.0
├── language-java@0.16.0
├── language-javascript@0.96.0
├── language-json@0.17.0
├── language-less@0.28.2
├── language-make@0.19.0
├── language-mustache@0.13.0
├── language-objective-c@0.15.0
├── language-perl@0.30.0
├── language-php@0.30.0
├── language-property-list@0.8.0
├── language-python@0.40.0
├── language-ruby@0.60.0
├── language-ruby-on-rails@0.23.0
├── language-sass@0.42.0
├── language-shellscript@0.19.0
├── language-source@0.9.0
├── language-sql@0.17.0
├── language-text@0.7.0
├── language-todo@0.27.0
├── language-toml@0.16.0
├── language-xml@0.33.0
├── language-yaml@0.24.0
├── line-ending-selector@0.2.0
├── link@0.31.0
├── markdown-preview@0.154.0
├── metrics@0.53.0
├── notifications@0.59.0
├── one-dark-syntax@1.1.1
├── one-dark-ui@1.1.5
├── one-light-syntax@1.1.1
├── one-light-ui@1.1.5
├── open-on-github@0.38.0
├── package-generator@0.40.0
├── release-notes@0.53.0
├── settings-view@0.230.0
├── snippets@0.100.0
├── solarized-dark-syntax@0.38.1
├── solarized-light-syntax@0.22.1
├── spell-check@0.61.0
├── status-bar@0.79.0
├── styleguide@0.44.0
├── symbols-view@0.109.0
├── tabs@0.84.0
├── timecop@0.33.0
├── tree-view@0.190.0
├── update-package-dependencies@0.10.0
├── welcome@0.30.0
├── whitespace@0.31.0
└── wrap-guide@0.38.0

/Users/conrad/.atom/packages (8)
├── editorconfig@1.2.0
├── language-babel@0.15.7
├── language-haskell@1.4.11
├── language-javascript-jsx@0.3.7
├── language-rust@0.4.5
├── linter@1.8.1
├── linter-jscs@3.1.1
└── react@0.12.10

How do I inspect atom logs, or otherwise reset this so Atom will work again?

Thanks!


#2

What happens when you:

  1. Close all instances of Atom … using the Force Quit menu if necessary
  2. Delete ~/.atom/storage
  3. Start Atom using atom --safe from the Terminal

#3

I still have the same results as before.

However, after re-deleting everything and redownloading everything and restarting my computer I got it to work. After more fiddling I’ve narrowed it down to this: I cannot run commands which spawn a GUI app from within a tmux pane. lol computers.

Here are some examples of the ways this fails:

$ open .
LSOpenURLsWithRole() failed with error -600 for the file /Users/conrad.

$ open some.txt
# TextEdit.app opens and has the same behavior as Atom did

$ atom some.txt
# Atom opens in the broken state as I had experienced before

Looking around I can find other people with this problem: https://github.com/atom/atom/issues/3093

Unfortunately I’m already using reattach-to-userspace, so… great. This is weird because the main reason I use reattach-to-userspace is to make clipboard stuff work, and that’s still functioning. For some reason now launching GUI apps isn’t.


#4

I’m having the same issue when trying to open Atom with black-screen. See my comments here:

Black Screen Pull Request

Any idea why this might be happening?


#5

@jdsimcoe are you running atom . from within a terminal inside tmux?


#6

No. I’m running inside Black Screen but nothing fancy.