Atom cannot save after 2 times

#1

I’m using atom 1.32.2 on arch linux (latest update)

I did some projects with atom and everything worked fine. But right now, when I open a file, I can work on it, save it with ctrl+s one time, then a second time and on the third time, it just won’t work in any way. Atom cannot save anymore. If I try to save it from “Save As” or simply "Save by clicking on it in the menu’s or closing while selecting save, it juste won’t work at all.

Any Idea where to look for? (I already watched file permissions, nothing to do here and it works with sublime or pycharm)

#2

Does this happen when you have Atom open in safe mode (atom --safe from the command line)?

#3

Yes, it still happen in safe mode.
I also get this problem sometime


I don’t know if it is linked to it or not, but none of my passwords are working. (also, I cannot screenshot with this popup window open, that’s why the picture quality is disgusting)

Anyway, that makes a lot of problems and I already tried to re install atom completely

#4

From what source?

#5

From the official arch mirrors and from AUR on arch (atom-editor-git)

#6

Problem solved somehow when I installed platformio for another project. (for the keyring, I tried my password again and it finaly passed)

1 Like