"Atom cannot be opened because of a problem" on Mac


#1

I’ve been using Atom on my Mac (running Yosemite 10.10.5) for a while now but for some unknown reason when I tried to launch it this morning from the Applications folder I got an error message and it wouldn’t open.

I’ve tried re-installing it from https://atom.io/ (v1.28.0), and also tried opening from the Terminal using open /Applications/Atom.app but the same error persists. When I try opening from the Terminal I get another error: LSOpenURLsWithRole() failed with error -10810 for the file /Applications/Atom.app.

Oh and the same thing happens even when I install Atom Beta, which I’ve never had installed before now. I know when you remove Atom from the Applications folder your settings/packages remain behind (presumably in Application Support or somewhere like that), but I didn’t want to have to do a complete wipe of the installation because it would mean losing all of my settings and installed packages.

Any help would be greatly appreciated.


#2

You can try earlier versions of Atom. It seems 1.28.0 has had issues with older Mac versions for a few people.


#3

Thanks, I tried rolling back to v1.21.2 - not ideal but the main thing is it works now and I haven’t lost all of my settings!


#4

Hello! may I ask how to download the earlier version please? I tried to search it online but didnt quite find it! Many thanks!!!


#5

I downloaded one of the versions from here.

I also tried v1.27.2 from here here, which worked.


#6

Pretty sure folks are hitting this issue (if you’re on macOS 10.10.x or lower and the crash happens with Atom 1.28 but not 1.27.2):

We suggest installing 1.27.2 and turning off auto-updating for now /cc Atom won't start all of a sudden and you can subscribe to https://github.com/atom/atom/issues/17565 for updates.

Previous Atom releases are available here:

E.g. https://github.com/atom/atom/releases/tag/v1.27.2

Going to go ahead and close as a duplicate for now.


#7