Atom can not connect to the internet to load packages and make updates


#21

I receive the following alert when I execute the following line:
> Z:\> apm install uber-juno
Installing uber-juno to C:\Users\hermesr.atom\packages failed
Request for package information failed: tunneling socket could not be establishe
d, cause=connect ETIMEDOUT 9.0.2.1:443 (5 attempts) (ECONNRESET)


#22

Is there any chance that you can try a different Internet access point that doesn’t include a proxy?


#23

It’s impossible for me. I try to work with atom in my job
I have read and tried to reproduce a few links similar to the following:
https://stackoverflow.com/questions/25997440/how-to-configure-atom-to-use-proxy-file-pac-settings
https://stackoverflow.com/questions/52448490/atom-using-system-proxy/52528490#52528490
https://stackoverflow.com/questions/48686716/tunneling-socket-could-not-be-established-statuscode-407-im-getting-this-error/52335359#52335359
https://stackoverflow.com/questions/52448490/atom-using-system-proxy/52528490#52528490

But so far without results.

However Rstudio does it perfectly!!!
Will it be possible to import the internet configuration from Rstudio to Atom?
How with Git I can find the Rstudio configuration?


#24

Atom relies on APM to install and update packages. However, there’s a possible workaround, since NPM works for you.

If you find a package you like, you can install it manually using git clone, since every Atom package has a GitHub repo (if there have been experimental commits to the master branch, you may need to git checkout the most recent release; I can coach you through this if you haven’t done it before). You can do this inside .atom/packages/ and Atom will load the packages automatically. Once you have the package code on your computer, you can use npm install to download all of the dependencies and run the install scripts (this is only necessary if the package actually has dependencies and/or install scripts). With this technique, you bypass apm entirely. You might never be able to automatically update your packages (unless you connect without a proxy; if you ever do, any packages that you have saved to .atom/packages/ will be able to be updated automatically), but Atom’s API is pretty stable so the majority of packages will be useful indefinitely into the future without changes. Some packages are in active development, but it would be up to you to keep up with them if there are any forthcoming changes that are relevant to you.

I believe that you would be perfectly comfortable using this method to “manually” (it’s still automated, but you’re removing one of the automation layers) install packages and use them for a lengthy period of time before you think about needing to update them. Atom usually doesn’t introduce any breaking changes and most of the quality packages in the ecosystem are feature-complete. Even if you end up a little behind on some updates, I don’t believe that would be a problem in any way unless one of the packages you rely on is a recently developed package that’s still getting its major features in place (uber-juno seems feature-complete to me as an outsider). I’ve done it a few times, for the purpose of developing packages, and it’s really a painless process.


#25

I have done what I have attached and without results!

Z:\>cd C:\Users\hermesr\AppData\Local\atom\packages

Z:\>git clone https://github.com/JunoLab/atom-julia-client.git
Cloning into 'atom-julia-client'...
ssh: connect to host github.com port 22: Connection timed out
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

Z:\>

Is there something wrong with the command lines?
Please guide me


#26

I have not experienced anything like this and am not sure how to proceed. I can only offer input regarding the Windows command line syntax: to cd from one drive to another you need the /d switch.


#27

the same result:

Z:\>cd /D C:\Users\hermesr\AppData\Local\atom\packages

C:\Users\hermesr\AppData\Local\atom\packages>git clone https://github.com/JunoLab/atom-julia-client.git
Cloning into 'atom-julia-client'...
ssh: connect to host github.com port 22: Connection timed out
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

C:\Users\hermesr\AppData\Local\atom\packages>

There is corporate proxy server!!!
Is that to take into account?


#28

Strange! Why this now?
How to proceed?

Z:>npm congig l -ls
‘npm’ is not recognized as an internal or external command,
operable program or batch file.

Z:>


#29

Do you have Node installed?


#30

Update the Path for apm and npm!
they are both working.
But I receive the following alerts:

Z:\> cd /D C:\Users\hermesr\.atom\packages

C:\Users\hermesr\.atom\packages>apm install https://github.com/saeidamiri1/rbox.git

Cloning https://github.com/saeidamiri1/rbox.git failed
Couldn't clone https://github.com/saeidamiri1/rbox.git

C:\Users\hermesr\.atom\packages>npm install https://github.com/saeidamiri1/rbox.git
npm ERR! Error while executing:
npm ERR! C:\Program Files\Git\cmd\git.EXE ls-remote -h -t https://github.com/sae
idamiri1/rbox.git
npm ERR!
npm ERR! undefined
npm ERR! exited with error code: 128

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\hermesr\AppData\Roaming\npm-cache\_logs\2018-11-09T08_21_2
9_181Z-debug.log

C:\Users\hermesr\.atom\packages>

#31

C:\Users\hermesr.atom\packages>git clone https://github.com/saeidamiri1/rbox.git
Cloning into ‘rbox’…
ssh: connect to host github.com port 22: Connection timed out
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

C:\Users\hermesr.atom\packages>


#32

this is the configuration:
I can see that the proxy is not declared

Z:\>npm config ls -l
; cli configs
long = true
metrics-registry = "https://registry.npmjs.org/"
scope = ""
user-agent = "npm/6.2.0 node/v8.9.3 win32 ia32"

; environment configs
node-gyp = "C:\\Users\\hermesr\\AppData\\Local\\atom\\app-1.32.1\\resources\\app
\\apm\\bin\\\\..\\node_modules\\node-gyp\\bin\\node-gyp.js"

; default values
access = null
allow-same-version = false
also = null
always-auth = false
audit = true
auth-type = "legacy"
bin-links = true
browser = null
ca = null
cache = "C:\\Users\\hermesr\\AppData\\Roaming\\npm-cache"
cache-lock-retries = 10
cache-lock-stale = 60000
cache-lock-wait = 10000
cache-max = null
cache-min = 10
cafile = undefined
cert = null
cidr = null
color = true
commit-hooks = true
depth = null
description = true
dev = false
dry-run = false
editor = "notepad.exe"
engine-strict = false
fetch-retries = 2
fetch-retry-factor = 10
fetch-retry-maxtimeout = 60000
fetch-retry-mintimeout = 10000
force = false
git = "git"
git-tag-version = true
global = false
global-style = false
globalconfig = "C:\\Users\\hermesr\\AppData\\Local\\atom\\app-1.32.1\\resources\
\app\\apm\\bin\\etc\\npmrc"
globalignorefile = "C:\\Users\\hermesr\\AppData\\Local\\atom\\app-1.32.1\\resour
ces\\app\\apm\\bin\\etc\\npmignore"
group = 0
ham-it-up = false
heading = "npm"
**https-proxy = null**
if-present = false
ignore-prepublish = false
ignore-scripts = false
init-author-email = ""
init-author-name = ""
init-author-url = ""
init-license = "ISC"
init-module = "C:\\Users\\hermesr\\.npm-init.js"
init-version = "1.0.0"
json = false
key = null
legacy-bundling = false
link = false
**local-address = undefined**
loglevel = "notice"
logs-max = 10
; long = false (overridden)
maxsockets = 50
message = "%s"
; metrics-registry = null (overridden)
**no-proxy = null**
node-options = null
node-version = "8.9.3"
offline = false
onload-script = null
only = null
optional = true
otp = null
package-lock = true
package-lock-only = false
parseable = false
prefer-offline = false
prefer-online = false
prefix = "C:\\Users\\hermesr\\AppData\\Local\\atom\\app-1.32.1\\resources\\app\\
apm\\bin"
production = false
progress = true
proxy = null
read-only = false
rebuild-bundle = true
registry = "https://registry.npmjs.org/"
rollback = true
save = true
save-bundle = false
save-dev = false
save-exact = false
save-optional = false
save-prefix = "^"
save-prod = false
scope = ""
script-shell = null
scripts-prepend-node-path = "warn-only"
searchexclude = null
searchlimit = 20
searchopts = ""
searchstaleness = 900
send-metrics = false
shell = "C:\\WINDOWS\\system32\\cmd.exe"
shrinkwrap = true
sign-git-commit = false
sign-git-tag = false
sso-poll-frequency = 500
sso-type = "oauth"
strict-ssl = true
tag = "latest"
tag-version-prefix = "v"
timing = false
tmp = "C:\\Users\\hermesr\\AppData\\Local\\Temp"
umask = 0
unicode = false
unsafe-perm = true
update-notifier = true
usage = false
user = 0
; user-agent = "npm/{npm-version} node/{node-version} {platform} {arch}" (overri
dden)
userconfig = "C:\\Users\\hermesr\\.npmrc"
version = false
versions = false
viewer = "browser"

Z:\>

#33

I don’t know the way around. I’ve had you poke at everything that I can think of. :confused: