Atom can not connect to the internet to load packages and make updates


#1

Atom does not manage to connect to the Internet, so it does not manage to update and load packages.
I have read a lot of posts and I have tried to reproduce the orientations described above, but without results.
All the time I receive the same alert: “self signed certificate in certificate chain”
What to do?
However Rstudio does it perfectly. Will it be possible to import the internet link configuration to Atom?
My connection is through an automatic configuration with script: “***. Pac”
Some help.
The same thing happens with Julia!


#2

Have you tried opening the command line and running

apm config set strict-ssl false

as mentioned in this FAQ post?


#3

Yes, I already executed those lines of code, and the result was the same.
I have installed, for more than once Atom and Julia, having cleaned the Windows registry. And without Result. Always the same alert:
“Self signed certificate in certificate chain”
But RStudio connects to the internet and performs the update and addition of new packages


#4

Does NPM work for you?


#5

Yes, it works after having updated the Path in the enviroment variables of windows, for apm and npm.
How could I attach a document with the result of NPM config l -ls?


#6

You can paste it into the forum, highlight the pasted text, and press the </> button above the editor.


#7

The result of NPM config l -ls:

; cli configs
long = true
metrics-registry = "https://registry.npmjs.org/"
scope = ""
user-agent = "npm/6.2.0 node/v8.9.3 win32 ia32"

; environment configs
node-gyp = "C:\\Users\\hermesr\\AppData\\Local\\atom\\app-1.32.0\\resources\\app\\apm\\bin\\\\..\\node_modules\\node-gyp\\bin\\node-gyp.js"

; default values
access = null
allow-same-version = false
also = null
always-auth = false
audit = true
auth-type = "legacy"
bin-links = true
browser = null
ca = null
cache = "C:\\Users\\hermesr\\AppData\\Roaming\\npm-cache"
cache-lock-retries = 10
cache-lock-stale = 60000
cache-lock-wait = 10000
cache-max = null
cache-min = 10
cafile = undefined
cert = null
cidr = null
color = true
commit-hooks = true
depth = null
description = true
dev = false
dry-run = false
editor = "notepad.exe"
engine-strict = false
fetch-retries = 2
fetch-retry-factor = 10
fetch-retry-maxtimeout = 60000
fetch-retry-mintimeout = 10000
force = false
git = "git"
git-tag-version = true
global = false
global-style = false
globalconfig = "C:\\Users\\hermesr\\AppData\\Local\\atom\\app-1.32.0\\resources\\app\\apm\\bin\\etc\\npmrc"
globalignorefile = "C:\\Users\\hermesr\\AppData\\Local\\atom\\app-1.32.0\\resources\\app\\apm\\bin\\etc\\npmignore"
group = 0
ham-it-up = false
heading = "npm"
https-proxy = null
if-present = false
ignore-prepublish = false
ignore-scripts = false
init-author-email = ""
init-author-name = ""
init-author-url = ""
init-license = "ISC"
init-module = "C:\\Users\\hermesr\\.npm-init.js"
init-version = "1.0.0"
json = false
key = null
legacy-bundling = false
link = false
local-address = undefined
loglevel = "notice"
logs-max = 10
; long = false (overridden)
maxsockets = 50
message = "%s"
; metrics-registry = null (overridden)
no-proxy = null
node-options = null
node-version = "8.9.3"
offline = false
onload-script = null
only = null
optional = true
otp = null
package-lock = true
package-lock-only = false
parseable = false
prefer-offline = false
prefer-online = false
prefix = "C:\\Users\\hermesr\\AppData\\Local\\atom\\app-1.32.0\\resources\\app\\apm\\bin"
production = false
progress = true
proxy = null
read-only = false
rebuild-bundle = true
registry = "https://registry.npmjs.org/"
rollback = true
save = true
save-bundle = false
save-dev = false
save-exact = false
save-optional = false
save-prefix = "^"
save-prod = false
scope = ""
script-shell = null
scripts-prepend-node-path = "warn-only"
searchexclude = null
searchlimit = 20
searchopts = ""
searchstaleness = 900
send-metrics = false
shell = "C:\\WINDOWS\\system32\\cmd.exe"
shrinkwrap = true
sign-git-commit = false
sign-git-tag = false
sso-poll-frequency = 500
sso-type = "oauth"
strict-ssl = true
tag = "latest"
tag-version-prefix = "v"
timing = false
tmp = "C:\\Users\\hermesr\\AppData\\Local\\Temp"
umask = 0
unicode = false
unsafe-perm = true
update-notifier = true
usage = false
user = 0
; user-agent = "npm/{npm-version} node/{node-version} {platform} {arch}" (overridden)
userconfig = "C:\\Users\\hermesr\\.npmrc"
version = false
versions = false
viewer = "browser"

#8

So the problem is solved now?


#9

No, I still do not have a link
I was referring to apm and npm, that with the installation I did not have access to them


#10

So I’ll repeat my question from earlier: does NPM work for you?

What do you get from apm config list?


#11
; cli configs
globalconfig = "C:\\Users\\hermesr\\.atom\\.apm\\.apmrc"
metrics-registry = "https://registry.npmjs.org/"
scope = ""
user-agent = "npm/6.2.0 node/v8.9.3 win32 ia32"
userconfig = "C:\\Users\\hermesr\\.atom\\.apmrc"

; environment configs
node-gyp = "C:\\Users\\hermesr\\AppData\\Local\\atom\\app-1.32.0\\resources\\app\\apm\\bin\\\\..\\node_modules\\node-gyp\\bin\\node-gyp.js"

; userconfig C:\Users\hermesr\.atom\.apmrc
proxy = "http://proxy.com:80/"
strict-ssl = false

; globalconfig C:\Users\hermesr\.atom\.apm\.apmrc
cache = "C:\\Users\\hermesr\\.atom\\.apm"
progress = false

; node bin location = C:\Users\hermesr\AppData\Local\atom\app-1.32.0\resources\app\apm\bin\node.exe
; cwd = C:\Users\hermesr
; HOME = C:\Users\hermesr
; "npm config ls -l" to show all defaults.

#12

It can be a bit dirty, since I have tried to reproduce recommendations read in the Forum.
And I do not know how to get to its initial state of installation


#13

Do you need to use the proxy? Can you try without it?

Change the name of C:\Users\hermesr\.atom\.apmrc so that the config file isn’t where APM looks for it.


#14

Switch to:
global config C: \ Users \ hermes \ .atom \ .apm \ .apmrc
Or
cache = “C: \ Users \ hermesr \. atom \. apm”
Tell me a little more, please!


#15

About what? You don’t switch to anything. If you want to use factory settings, just remove the settings file entirely (and .atom/.apm/.apmrc if you have one).


#16

I deleted the file:

I was referring to:
Change the name of C: \ Users \ hermesr \ .atom \ .apmrc

Switch to:
global config C: \ Users \ hermes \ .atom \ .apm \ .apmrc
Or
cache = "C: \ Users \ hermesr . atom \ apm "


#17

For me it’s because my school has a proxy that requires authentication. Using APM rather than the atom GUI seems to work, sort of


#18

You’re going to need to use longer sentences with more punctuation. In no way does your post come across as a question.

You change the name so that you aren’t deleting the file. It doesn’t matter what you change the name to (but you shouldn’t just move it to where the global configs are, because that would defeat the point). Just do apmrc-backup.txt. That would be perfectly understandable.


#19

This is the alert I receive at this time:

tunneling socket could not be established, cause = connect ETIMEDOUT 34.194.132.99:80

after having configured the apm with these lines of code:

https-proxy = "http://proxy.com:80/"
strict-ssl = false

#20

I’m not familiar with the possible causes of that error. Maybe someone else is.