Atom broke node-webkit/chromium


Hey, I installed (Windows 7) atom to check it out along with atom-shell. As soon as I did, it broke a project I am working on in node-webkit. The webpage in node is now zoomed in (which atom also looked a little fuzzy), and the icons and scrollbars are bright red in node-inspector and the node-webkit app. I immediately removed chocolatey, atom, and everything I could find, but it is still broken, so I am guessing that atom changes some chromium content registry settings or something that is causing the issues.

Has anyone else seen this or have any ideas on fixing it? No system restore point was created for the choco/atom install and too much has changed since the last one to try that.

debug.log has the following:

[2900:0814/] Unable to load image with id 5586
[2900:0814/] Unable to load image with id 5584
[2900:0814/] Unable to load image with id 5585
[2900:0814/] Unable to load image with id 5588
[2900:0814/] Unable to load image with id 5587
[2900:0814/] Unable to load image with id 5591
[2900:0814/] Unable to load image with id 5589
[2900:0814/] Unable to load image with id 5590
[2060:0814/] Unable to load image with id 5824
[2060:0814/] Unable to load image with id 5823
[2060:0814/] Unable to load image with id 5825
[2060:0814/] Unable to load image with id 5821

I realize this isn’t the node-webkit group, but since atom uses chromium and installing atom is what broke it, I am hoping someone may have some clues here. Thanks


Nobody else that I’ve seen has reported something like this. To my understanding, even on Windows Atom uses a self-contained copy of both Node and Chromium … so I’m not sure how this would happen. Then again, I’m not the expert on such things :grinning:

cc @kevinsawicki, @zcbenz


Another clue as to what is going on:
In my %APPDATA%/Local/::nodewebkitapp::/Cache folder, I am now seeing a bunch(8-10) of orphaned files after each run, beginning at the time of the atom install. There are no files in that folder from the hundreds of other times it was run before atom was installed. My guess is that this is related…some node/chromium/etc has changed on my system due to the atom install.


Are you using a high DPI display by any chance?
At least the “zoomed in” look rings a bell, in that Chromium 36 (which is now included in atom shell) started supporting high DPI screens by scaling them up like it was meant to support blind users.

Not sure about the errors though.


More info: The files that are showing up in the Cache folder now are devtools related files, images/css. So I am guessing now that something global about devtools has changed with the atom install?


I have my display set to 150% (with Windows XP DPI Scaling checked) if that is what you mean by high dpi. So the question is where are these settings being stored locally? Why would this persist after atom was uninstalled? I can confirm that my node-webkit app is using Chromium35.


Ok, so yes, reverting my display settings back to 100% from 150%, the red squares are no longer present and the images and scrollbars returned to normal, and the zoom is fine.

Returning to 150%, the images/scrollbars work, but the window is zoomed again(which was not the case before istalling atom). This setting is persisting from atom to other non-atom chromium instances somehow.

[EDIT] Spoke too soon. Forgot that you have to set the Windows XP Scaling twice to get it to work. The red boxes are back when windows xp scaling is re-enabled. So resetting the display to 100% (and tiny fonts for everything else) works, scaling and not using XP Scaling, some apps are blurry including chromium, and using XP scaling some images don’t load and show red boxes instead.

I guess it isn’t strictly an atom issue, just caused by my install of atom. If anyone has any ideas on how to fix this, please chime in. I don’t even have chrome/chromium installed as a browser otherwise (no real tree style tabs, so no go for me).

Thanks for helping me narrow it down batjko!


So the answer is that Atom and Node-webkit versions of Chromium content library both use a registry setting:
HKCU/Software/Google/Chrome/Profile/high-dpi-support(DWORD), even if you don’t have Chrome installed.
Setting to 0 solves this problem for me.
Thanks again to batjko for putting me on the right path.


You did all the work yourself. Thanks for adding that workaround, @slaingod.

Hopefully, this issue is going to be fixed for good in Chromium soon.