ATOM becomes unresponsive after switching back to ATOM from a window


#1

Hello guys,

ATOM is a very nice editor, I love it!

But there’s a huge problem, when I have ATOM minimized and I am on a different window when I come back ATOM becomes unresponsive for 7-8 seconds. This means I can not edit anything without waiting, the typing cursor (the one that flashes) appears only after I’ve waited for a while.

I was curious what could the reason be for this. My friend whom uses the same packages as me and is working on the same project is not facing any issues. My computer is a powerful, i7 5700HQ with 8GB RAM.


#2

Just to confirm, do you see the same behavior in safe mode?

  • Completely exit all instances of Atom
  • Launch Atom with the command atom --safe

Also, do you see this behavior all the time or only when you’re have a particular project open?


#3

Sorry forgot to ask - can you also share some version information about Atom and your system?

  • atom --version
  • apm --version
  • Your operating system and OS version

#4

Behaviour is same with 2 different projects at the same API (scripting language) I also tried a very minimalistic project again with the same API (scripting language) to make sure its not because of the quantity of the files and the results are same.

I uncollapsed both projects (from the left of the screen, I dont know if that helps) closed all files related to the projects and opened a new, blank file “untitled” and its still same.

Windows 10 Pro 64bit (10.0 , 14393)

Microsoft Windows [Version 10.0.14393]
© 2016 Microsoft Corporation. Tüm hakları saklıdır.

C:\WINDOWS\system32>atom --safe

C:\WINDOWS\system32>atom --version

Atom : 1.15.0
Electron: 1.3.13
Chrome : 52.0.2743.82
Node : 6.5.0

C:\WINDOWS\system32>apm --version
apm 1.15.3
npm 3.10.5
node 4.4.5 ia32
python
git
visual studio

C:\WINDOWS\system32>


#5

Procedures said above were all done safe mode enabled.


#6

Thanks for the details - did this just start happening recently, or have you always seen this behavior?

And can you confirm if you have any anti-virus software on your system?


#7

I have malwarebytes and avast installed. The incident was also occuring before I installed malwarebytes. The ATOM editor has always been like this and it’s not new.


#8

Btw I noticed that, if I have a fairly smaller window compared to ATOM (skype etc.) and if I hover with my mouse to the tabs for the files on top of the screen without switching back to ATOM, (so having the other window still on top of ATOM) the tabs highlight but the moment I click one of those tabs, ATOM becomes unresponsive again and I have to wait for it to be settle.


#9

I’ve seen a few reports where people mention that their anti-virus program had some effect on Atom. Just to test, can you try temporarily disabling Avast and see if the behavior changes?


#10

Very interesting, with AVAST enabled the reload time is 8 seconds and when AVAST is disabled it takes 2 seconds to recover.

I disabled Malwarebytes as well and the recover time is instant, no delay at all.

I thought Malwarebytes had no effect, but apparently it had a 2 seconds addition but I didn’t notice that since the recover time was too long already.

Okay, I enabled both now but we all know I can’t use a computer without an antivirus, what should I do? Add ATOM to the excluded softwares?


Anyone here notice the lag in atom when malwarebytes is running even in idle?
#11

Okay, I enabled both now but we all know I can’t use a computer without an antivirus, what should I do? Add ATOM to the excluded softwares?

Yeah that’s the approach other folks seem to have taken - I don’t use Avast but I saw a recent recommendation for paths to exclude /cc https://github.com/atom/atom/issues/7191#issuecomment-274361358.


#12

This may also be an issue with Git - see https://github.com/atom/atom/issues/9544.


#13

Do you know how to do it for Malware bytes as well? I did it on AVAST and the delay is 2 seconds now, which means malwarebytes is interfering


#14

Just to confirm this I closed malwarebytes completely (even though I had the exclusions) and the recover time is instant.

Sorry if I am flooding the forums, there’s no edit button.


#15

No problem at all but just to confirm, are you all set with the Malware Bytes exclusions that you added? Thanks for dropping the screenshot :v:


#16

As seen in the screenshot, I’ve done all exclusions but they are not taking into effect. The delay still occurs, even after restarting my computer. Could there be any extra directories I need to exclude? These worked for AVAST, but Malwarebytes still causes some delay.


#17

Sorry I’m not sure if there are other directories that might be useful to try excluding with Malware Bytes, I think those 2 directories are the main ones.

But I just noticed that I missed @Wliu’s comment above:

Can you confirm if the projects you’ve been using when you see this behavior are git repositories?


#18

They are repositories, but not github. I use gitlab. But It seems like it’s related to my antivirus because when I disable them it’s all good.


#19

As long as you’re using a git repository locally, it shouldn’t matter if you remotely host the repository on GitHub or GitLab or some other service.

I went ahead and installed Malware Bytes and then took a test project that was a git repository to test. I then copied the project to a different directory but removed the .git/ directory so it’s no longer a git repository. I then opened 2 different Atom windows with each project.

With Malware Bytes enabled, I see the ~2 second delay when switching to the git repository version of the project. But when switching to the same project that’s not a git repository, there’s no delay. Can you confirm if you see this behavior as well if you make a copy of one of your projects but just remove the .git/ directory in the copy?


#20

Yeah, there’s no delay when I remove .git/ directory