Atom-beautify large indent


#1

Hey guys.

I hope you can help me with my Atom Configuration. I have installed atom-beautify to format my documents in Atom. And the format function is working very good in some documents HTML for example. But in C the indent size is a way to big.

Maybe because atom-beautify uses uncrustify to format C Code and I have to change the Settings from uncrustify to the settings from Atom?

Greets
Dennis


#2

Do you mean that atom-beautify is inserting too many tabs on C files, or that the tabs themselves are too large on C files? Mind taking a screenshot so we can see what you see?


#3

I mean atom-beautify is inserting too many tabs.

Here is one picture how It should look like:
[URL=http://www.bilder-upload.eu/show.php?file=4b315d-1493997737.png][/URL]


#4

Here is picture how atom-beautify format at the moment:
[URL=http://www.bilder-upload.eu/show.php?file=c83e6d-1493997769.png][/URL]

P.S.: Have to Reply two times. I am only allowed to post one picture in one post :sweat_smile:


#5

Looks like I have to change something in the uncrustify config:
http://uncrustify.sourceforge.net/default.cfg

Has Somebody maybe already done this?

  • How can I change the config from uncrustify?
  • Which settings should I change so that uncrustify formats like the other languages format in atom-beautify?

#6

When I look in .atom\packages\atom-beautify\src\beautifiers\uncrustify/, I find a file called default.cfg. You can probably fix it by playing around with the identation rules.


#7

I have changed the settings input_tab_size, output_tab_size and indent_columns to 1.
After that restart my Atom. It didn’t changed something, the indent size is too big.


#8

Aaaaah, now I got it. Have to change the Configpath in the settings from atom-beautify.