Atom auto-delete the space between > > when saving


#1

Hi,
When I declare a matrix : vector<vector > matrix, Atom delete the space between > > when I save.
The declaration become : vector<vector> matrix, whicj is wrong.
Please, tell me how resolve that.
Thanks.


#2

The atom plugin whitespace does white space normalisation uppon saving.

I’d try to disable it. Then if your problem is solved re-enable it but uncheck the setting that cause problem.


#3

The whitespace package only trims whitespace at the end of a line by default, not in the middle like @blackbird is describing.


#4

Is there a solution for that ?


#5

First try to see if it happens in safe mode atom --safe
If yes, i’d still check if disabling white space help quick and easy to do.


#6

The whitespace package only trims whitespace at the end of a line by default.

That is true. When the package does what is designed to do.
There’s not one million default package that does transform on file save.
And there’s been previous report of whitespace miss-behaving

I however realized the author didnt try atom safe so it could be another package too.


#7

atom --safe works, but I think it will disable some packages such as terminal-plus.
I resoved the problem by complling using -std=c++11.