Atom app crash


#1

I’m hoping someone can help me out with getting atom installed and working as the app seems to crash all the time.

So, I am using a corporate laptop, windows 8, 64-bit with 8Gb ram.
I had managed to install atom previously and it loaded and worked without issue. When I tried to load the app the next day it crashed. So, I uninstalled and reinstalled, and instantly crashes when trying to open following installation and I cannot figure out why.

I have local admin to my machine, and I’m running chrome, which I use to download the installer, in admin mode, as well as running the installer as admin. I’ve tried opening Atom as admin - still crashes.

I’ve uninstalled, rebooted, installed = Crash.
I’ve uninstalled, rebooted, installed, rebooted = Crash.

All i get for the crash info is the following:

Problem signature:
Problem Event Name: APPCRASH
Application Name: atom.exe
Application Version: 1.28.1.0
Application Timestamp: 5b3bcb5d
Fault Module Name: node.dll
Fault Module Version: 8.9.3.0
Fault Module Timestamp: 5b3bc880
Exception Code: c0000005
Exception Offset: 0000000000241ef2
OS Version: 6.3.9600.2.0.0.256.4
Locale ID: 2057
Additional Information 1: c1f4
Additional Information 2: c1f4002ba914057584330be99fb1b1ca
Additional Information 3: 192c
Additional Information 4: 192c4b8b0a146bbd75646436c90c9236

Any help would be appreciated

Kind regards,

~D.A


#2

What follows is a personal opinion and not in an official capacity.

Could you please try and revert to an earlier version of Atom.
Let us say V1.26.1 (https://github.com/atom/atom/releases/tag/v1.26.1).
Make sure to de-activate automatic updating.
What is the result then?



Update: Today I was ‘forced’ to take my own advice (installing V1.26.1).
Some mouse scroll event [sic] was blocked originating from Chrome(?) / Electron(?).

I was messing around with styles / minimap settings.
After an Atom reboot, the system refused to start or took ‘minutes’ to render any text.
Safe mode and deletion of all customizations did not save my V1.28.1 install.

It seems to be stable on V1.26 now with most/all customizations in place.


#3

Apologies, it’s been a hell of a day today, and I’m afraid I haven’t had chance to try and older version as of yet.

It’s good to know that everything seems to be stable however.

If I get chance later I’ll give this a try, if not I’ll have to look into it tomorrow - bare with me.

~D.A


#4

Okay, So I installed V1.26 this morning and so far so good. App loaded after install without errors, so I’m hopeful that this will be it.

I’ll give it a couple days and see what we’re like and I’ll update if there are any more issues.

~D.A


#5

After using V1.26 for about a week, I still have not had any issues with it and it seems to work perfectly.

Thanks so much for the suggestion, this has solved my problems!

Kind regards,

~D.A


#6

Thank you for the good news.
It better to have a stable app than being just shy of the cutting edge

I have been running Atom V1.28.2 for a while and did not see big issues.

If there is no compelling reason to update, then stay where you are. Else try the updated version or wait for the next one in a few days.