Atom and x2go


#1

Hy,

I ran into some troubles with Atom on our terminalserver running on arch.
We are working on it with x2go and everytime we want to start atom, we get the following error message:

[28848:0630/105707:ERROR:browser_main_loop.cc(170)] Running without the SUID sandbox! See https://code.google.com/p/chromium/wiki/LinuxSUIDSandboxDevelopment for more information on developing with the sandbox on.
App load time: 469ms
ATTENTION: default value of option force_s3tc_enable overridden by environment.
[28881:0630/105707:ERROR:gl_surface_glx.cc(357)] GLX 1.3 or later is required.
[28881:0630/105707:ERROR:gl_surface_x11.cc(56)] GLSurfaceGLX::InitializeOneOff failed.
[28881:0630/105707:ERROR:sandbox_linux.cc(325)] InitializeSandbox() called with multiple threads in process gpu-process
atom: Fatal IO error 104 (Connection reset by peer) on X server :50.

Does anybody have an idea what to do in order to get it working?

brgds


#2

I’d search the Atom Issues for similar error messages. Check here for tips on how to search best:


#3

Thank you.
I saw that there are a few people with the similar kind of problem, but I haven’t found a solution.

Or I am blind, which could be possible as well :smile:

brgds


#4

Just tried exactly the same today. I’m thinking the clue might be the “GLX 1.3 or later is required”. X2go only supports v1.2

Lets hope we can find a solution/workround.


#5

If I find a solution/workaround, I will let you know


#6

2 years later… I just ran into this very bug. Downloaded and installed x2go client and server and unpacked atom from atom-amd64.tar.gz. I ran a strace and it ends with a connection reset by peer error

...
writev(24, [{"\22\0\0\0\v\0 \0\1\0`\0\v\1\0\0\6\0\0\0 \2\0\0\4\0 \0\0\4\0\0"..., 16384}, {NULL, 0}, {"", 0}], 3) = 16384
recvmsg(24, 0x7ffc487b0840, 0)          = -1 ECONNRESET (Connection reset by peer)
exit_group(1)                           = ?
+++ exited with 1 +++

I tried following the instructions here but it didn’t work.

Any other ideas how to get this to work?