Atom and long files


#1

Hi,

I already posted something about this in Dec 17 ( Long files –> extreme slow reaction from Atom).
I want to stir this up and see if somebody has a good explication, can give some hints or …

I use atom 1.23.3 x64 on Ubuntu_16.04.3 and on WIndows-10.
Using atom on Ubuntu starts reacting very slow when a file gets long (> 1000 lines)
Using the exact the same files with atom on Windows works as a charm (no getting stuck for a while or other issues).
I have atom installed on both OSses with the same packages (Markdown and VHDL).

Anybody any idea why the same atom version with the same packages works flawless on Windows and works with hiccups on Ubuntu?

Thanks,

Marc


#2

Though you only have the 2 community packages installed, do you see the same behavior in safe mode (atom --safe) or if you temporarily reset to factory defaults? Also, are you able to share an example file that reproduces the behavior for you so we can give it a try?

Lastly, are there any devtools console errors when you run on Ubuntu?

http://flight-manual.atom.io/hacking-atom/sections/debugging/#check-for-errors-in-the-developer-tools


#3

Hi rsese,

I have following packages installed:
Column-select, highlight-selected, language-markdown, language-vhdl, linter-markdown (this installed also
linter, busy-signal, intentions, linter-ui-default) linter-vhdl, markdown-preview-enhanced, minimap, minimap-highlight-selected, and split-diff.

I’ve removed all atom stuff for my Ubuntu system and re-installed everything again. Left everything with in teh mode it’s installed in. Behaviour is identical, loading teh files is ok and it works for a while OK but then it starts to slow down. slowing down is as if something cannot follow the tool. Example: Typing works fine as long you are typing but when stopping it is as if something needs to be written somewhere before the tool can accept new typing. The same happens when typing and stopping to scroll to another place in the document. After stopping typing it takes a while before scrolling can start (or moving teh box in the minimap up or down).

I cannot share documents – company proprietary/secret stuff –
No errors in dev-mode.

Regards,


#4

To get a proper list of your packages please provide the results of apm list. This ensures the version number is there, and you don’t accidentally leave any packages out.

When pasting it, also make sure it is fenced by ```
For example,

```plain

<paste here>

```

#5

Hallo Aerijo,

This is what you are asking for:
The list of installed community packages for Atom_1.23.3 x64 installed on
Ubuntu_16.04.3 and WIndows_10.

e[36mCommunity Packages (15)e[39m /home/marc/.atom/packages
├── busy-signal@1.4.3
├── column-select@1.0.1
├── highlight-selected@0.13.1
├── intentions@1.1.5
├── language-markdown@0.25.1
├── language-vhdl@0.7.2
├── linter@2.2.0
├── linter-markdown@5.2.0
├── linter-ui-default@1.6.10
├── linter-vhdl@1.1.4
├── markdown-preview-enhanced@0.15.2
├── minimap@4.29.7
├── minimap-highlight-selected@4.6.1
├── split-diff@1.5.2
└── vhdl-entity-converter@0.4.

Regards,

Marc


#6

Aerijo,

For completeness here all default, built in, packages installed by Atom.
Shows the ones I disabled.

e[36mBuilt-in Atom Packagese[39m (92)
├── atom-dark-syntax@0.28.0
├── atom-dark-ui@0.53.0
├── atom-light-syntax@0.29.0
├── atom-light-ui@0.46.0
├── base16-tomorrow-dark-theme@1.5.0
├── base16-tomorrow-light-theme@1.5.0
├── one-dark-ui@1.10.8
├── one-light-ui@1.10.8
├── one-dark-syntax@1.8.0
├── one-light-syntax@1.8.0
├── solarized-dark-syntax@1.1.2
├── solarized-light-syntax@1.1.2
├── about@1.7.8
├── archive-view@0.64.1
├── autocomplete-atom-api@0.10.5
├── autocomplete-css@0.17.4
├── autocomplete-html@0.8.3
├── autocomplete-plus@2.40.0
├── autocomplete-snippets@1.11.2
├── autoflow@0.29.0
├── autosave@0.24.6
├── background-tips@0.27.1
├── bookmarks@0.44.4
├── bracket-matcher@0.88.0
├── command-palette@0.42.0
├── dalek@0.2.1
├── deprecation-cop@0.56.9
├── dev-live-reload@0.47.1
├── encoding-selector@0.23.7
├── exception-reporting@0.42.0
├── find-and-replace@0.215.0
├── fuzzy-finder@1.7.3
├── github@0.8.3 (disabled)
├── git-diff@1.3.6 (disabled)
├── go-to-line@0.32.1
├── grammar-selector@0.49.8
├── image-view@0.62.4
├── incompatible-packages@0.27.3
├── keybinding-resolver@0.38.1
├── line-ending-selector@0.7.4
├── link@0.31.3
├── markdown-preview@0.159.18 (disabled)
├── metrics@1.2.6 (disabled)
├── notifications@0.69.2
├── open-on-github@1.3.1 (disabled)
├── package-generator@1.1.1
├── settings-view@0.253.1-0
├── snippets@1.1.9
├── spell-check@0.72.5
├── status-bar@1.8.14
├── styleguide@0.49.8
├── symbols-view@0.118.1
├── tabs@0.109.1
├── timecop@0.36.0
├── tree-view@0.221.3
├── update-package-dependencies@0.12.0
├── welcome@0.36.6 (disabled)
├── whitespace@0.37.5
├── wrap-guide@0.40.2
├── language-c@0.58.1
├── language-clojure@0.22.4 (disabled)
├── language-coffee-script@0.49.3
├── language-csharp@0.14.3 (disabled)
├── language-css@0.42.7
├── language-gfm@0.90.2 (disabled)
├── language-git@0.19.1
├── language-go@0.44.3 (disabled)
├── language-html@0.48.5
├── language-hyperlink@0.16.3
├── language-java@0.27.6
├── language-javascript@0.127.6
├── language-json@0.19.1
├── language-less@0.33.0
├── language-make@0.22.3
├── language-mustache@0.14.4 (disabled)
├── language-objective-c@0.15.1 (disabled)
├── language-perl@0.38.1 (disabled)
├── language-php@0.42.2 (disabled)
├── language-property-list@0.9.1 (disabled)
├── language-python@0.45.5
├── language-ruby@0.71.4 (disabled)
├── language-ruby-on-rails@0.25.2 (disabled)
├── language-sass@0.61.1 (disabled)
├── language-shellscript@0.25.4
├── language-source@0.9.0
├── language-sql@0.25.8
├── language-text@0.7.3
├── language-todo@0.29.3
├── language-toml@0.18.1 (disabled)
├── language-typescript@0.2.2
├── language-xml@0.35.2
└── language-yaml@0.31.1 (disabled)

#7

Using atom on Ubuntu starts reacting very slow when a file gets long (> 1000 lines)

Do you see the slowdown with any long files or just the files from this particular project you’re working?

Can you tell us anything else about the files you’re working on that might be helpful? E.g. are there long lines in the file? What type of files are they? Are you working in a Git repository?


#8

Hi,

It is VHDL project, so I can only tell that the, call it: staggering, happens with those files.
I wrote some markdown readme files with the VHDL file, but they are all short and did not have the issue.

The file type of a VHDL file is following: “editor: log cursor scope”:
source.vhdl
comment.line.double-dash.vhdl

The files do not have long lines, all lines are never longer than 120 characters and most are shorter than 96 characters.
Everything is local stored, nothing goes on Github.

The project is a top level folder containing sub-folders and sub-folders, like:

/<Root Level>
	/Documents
		PDF, schematic and other documentation files
	/Libraries
		/<One>_Lib
		  /Documents
		  /Libraries
		  		This are the root libraries, hierrachy stops here.
		  /SimScripts
		  /SImulation
		  /Vhdl
	/SimScripts
	   Folder with TCL scripts
	/Simulation
	/Vhdl
	   <Toplevel.vhd>
	   All toplevel vhd file go here.
	   Top level vhd files include test bench and stimulus files.

When working with Atom, I open the /<Root Level> folder to start working on different .vhd and other files.

Hope this helps

Marc


#9

Hmmm, not sure what else might be going on - can you see if installing the latest stable release (currently 1.24.0) makes a difference? And if you try the beta (https://atom.io/beta), do you see the same problem there as well?

Edit: if you try the different versions, please test in safe mode.