Atom adds too many indent after an @include


#1

Hi,
I’m new Atom before I was using Coda but it begins to get old.
I am now on Atom and since 2 weeks, I’m set Atom with my preferences.

I have two issues:

  • .scss files with sass Color syntax

  • When I write in my .scss sass files, when I do an @include then when I go to the Atom line adds 4 more space and that’s only when the Sass syntax is selected not when the SCSS is.

SCSS - ok

Sass. - No ok


#2

Your images aren’t loading.


#3

Sorry, it’s ok now


#4

I don’t see where in the language package that would be happening. Please run apm ls from the command line and share the list of packages you have installed.


#5

Built-in Atom Packages (89)
├── atom-dark-syntax@0.27.0
├── atom-dark-ui@0.52.0
├── atom-light-syntax@0.28.0
├── atom-light-ui@0.44.0
├── base16-tomorrow-dark-theme@1.2.0
├── base16-tomorrow-light-theme@1.2.0
├── one-dark-ui@1.6.0
├── one-light-ui@1.6.0
├── one-dark-syntax@1.3.0
├── one-light-syntax@1.3.0
├── solarized-dark-syntax@1.0.2
├── solarized-light-syntax@1.0.2
├── about@1.7.0
├── archive-view@0.61.1
├── autocomplete-atom-api@0.10.0
├── autocomplete-css@0.11.2
├── autocomplete-html@0.7.2
├── autocomplete-plus@2.31.1
├── autocomplete-snippets@1.11.0
├── autoflow@0.27.0
├── autosave@0.23.1
├── background-tips@0.26.1
├── bookmarks@0.42.0
├── bracket-matcher@0.82.1
├── command-palette@0.38.0
├── deprecation-cop@0.54.1
├── dev-live-reload@0.47.0
├── encoding-selector@0.22.0
├── exception-reporting@0.40.0
├── find-and-replace@0.201.1
├── fuzzy-finder@1.4.0
├── git-diff@1.1.0
├── go-to-line@0.31.0
├── grammar-selector@0.48.2
├── image-view@0.59.0
├── incompatible-packages@0.26.1
├── keybinding-resolver@0.35.0
├── line-ending-selector@0.5.0
├── link@0.31.1
├── markdown-preview@0.158.0
├── metrics@1.0.0
├── notifications@0.65.1
├── open-on-github@1.2.0
├── package-generator@1.0.0
├── settings-view@0.242.2
├── snippets@1.0.2
├── spell-check@0.68.2
├── status-bar@1.4.1
├── styleguide@0.47.0
├── symbols-view@0.113.1
├── tabs@0.101.0
├── timecop@0.33.2
├── tree-view@0.209.3
├── update-package-dependencies@0.10.0
├── welcome@0.35.1
├── whitespace@0.33.0
├── wrap-guide@0.38.2
├── language-c@0.52.1
├── language-clojure@0.21.0
├── language-coffee-script@0.47.2
├── language-csharp@0.12.1
├── language-css@0.37.1
├── language-gfm@0.88.0
├── language-git@0.15.0
├── language-go@0.42.1
├── language-html@0.45.1
├── language-hyperlink@0.16.0
├── language-java@0.23.0
├── language-javascript@0.119.0
├── language-json@0.18.2
├── language-less@0.29.5
├── language-make@0.22.2
├── language-mustache@0.13.0
├── language-objective-c@0.15.1
├── language-perl@0.35.0
├── language-php@0.37.2
├── language-property-list@0.8.0
├── language-python@0.45.0
├── language-ruby@0.69.0
├── language-ruby-on-rails@0.25.0
├── language-sass@0.56.0
├── language-shellscript@0.22.4
├── language-source@0.9.0
├── language-sql@0.23.0
├── language-text@0.7.1
├── language-todo@0.28.0
├── language-toml@0.18.0
├── language-xml@0.34.9
└── language-yaml@0.26.0

Community Packages (13) /Users/matthieu/.atom/packages
├── Atom-Syntax-highlighting-for-Sass@0.5.0
├── Sass-Syntax-Highlight@0.1.1
├── Sublime-Style-Column-Selection@1.7.2
├── autoclose-html@0.23.0
├── autocomplete-sass@0.1.0
├── emmet@2.4.3
├── file-icons@1.7.22
├── highlight-selected@0.11.2
├── minimap@4.25.0
├── minimap-highlight-selected@4.4.0
├── pigments@0.37.0
├── specials-board@0.8.0
└── todo-show@1.7.0

└── (empty)


#6

Does the extra indentation happen when you start Atom from the command line with atom --safe?


#7

It not happens on SCSS syntax but it’s happens when I select Sass in syntax grammar. Like in not safe mode.
I think you’re right, I must use SCSS syntax grammar, and color the syntax theme, and my two issues will be solved.

Right ?


#8

If it doesn’t happen in safe mode, then it’s one of the packages doing it. You can try disabling packages until it stops happening.


#9

It doesn’t happen in safe mode LIKE AS not safe mode. Same results.
But here you say me to use SCSS syntax.
I must color this syntax with my theme and it will be ok

Thanks


#10

I’m not here to tell you what to do, just what your options are. :slight_smile: