Atom 1.35.0 won't start on Ubuntu 14.04


#1

Hello,

I’m currently using Ubuntu 14.04 (an upgrade to 18.04 is planned).
Atom was installed using the “official package repository” as described here:
https://flight-manual.atom.io/getting-started/sections/installing-atom/#debian-and-ubuntu-debapt

Yesterday, Atom was updated from version 1.34.0 to version 1.35.0.
Since then, it won’t start. No window opens. Running the atom command from the terminal does not produce any output (no error messages).
However, there are several atom processes running, as shown by ps aux | grep atom:

user3 29272  0.0  0.0  15264   636 ?        S    09:28   0:00 /bin/bash /usr/bin/atom
user3 29274  7.3  0.8 1316880 136568 ?      Sl   09:28   0:00 /usr/share/atom/atom --executed-from=/home/user3 --pid=29259
user3 29276  0.1  0.1 360084 21720 ?        S    09:28   0:00 /usr/share/atom/atom --type=zygote --no-sandbox
user3 29304  1.5  0.2 402540 40508 ?        Sl   09:28   0:00 /usr/share/atom/atom --type=gpu-process --no-sandbox --supports-dual-gpus=false --gpu-driver-bug-workarounds=9,27,84 --disable-gl-extensions=GL_KHR_blend_equation_advanced GL_KHR_blend_equation_advanced_coherent --disable-accelerated-video-decode --gpu-vendor-id=0x10de --gpu-device-id=0x0f00 --gpu-driver-vendor=Nvidia --gpu-driver-version=384.130 --gpu-driver-date --service-request-channel-token=1234567890ABCDEF123456789ABCDEF1

Killing the 2nd process kills them all.

apt-get remove didn’t help. Neither did apt-get purge.
I also tried renaming the .atom folder to .atom.old, to no avail.

Version 1.34.0 still works.

When attempting to run Atom 1.35.0 without a .atom folder, it creates one, with just 1 file in it, nohup.out, with the following content:

A JavaScript error occurred in the main process
Uncaught Exception:
Error: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/share/atom/resources/app.asar.unpacked/node_modules/nslog/build/Release/nslog.node)
    at process.module.(anonymous function) [as dlopen] (ELECTRON_ASAR.js:166:20)
    at Object.Module._extensions..node (module.js:671:18)
    at Object.module.(anonymous function) [as .node] (ELECTRON_ASAR.js:180:18)
    at Module.load (module.js:561:32)
    at tryModuleLoad (module.js:504:12)
    at Function.Module._load (module.js:496:3)
    at Module.require (module.js:586:17)
    at require (internal/module.js:11:18)
    at Object.<anonymous> (/usr/share/atom/resources/app.asar/node_modules/nslog/lib/nslog.js:5:11)
    at Object.<anonymous> (/usr/share/atom/resources/app.asar/node_modules/nslog/lib/nslog.js:15:4)

#2

I’m encountering the same issues on CentOS 7.

Reinstall didn’t help.


#3

First point I make is don’t “upgrade” from Ubuntu 14.04 to 18.04. It is safer to do a fresh installation of Ubuntu 18.04 (when you are ready) and then migrate files into the fresh installation.

I have Ubuntu 16.04 running and on reading this thread I installed Atom 1.35 (previously 1.34 installed). I downloaded the *.deb file and used GDebi Package Installer. This appears to work so far without errors.


#4

Yes, I intend to do a fresh install of Ubuntu 18.04, not actually upgrade.


#5

Another user had the same issue with version 1.35.0 on RHEL 7.6: https://github.com/atom/atom/issues/18974

He said that version 1.35.1 worked for him.

I can confirm, no problem with the new version.