Atom (1.33.0) crashed and will not reopen MacOs Mojave 10.14.1


#1

I am new to software development I was using it to connect with Sourcetree to then push code blocks to a GitHub repository for a class assignment. It was working fine for a few minutes and then began to lose functionality. So I tried to close the window first and then the whole application, but the window would not close even though the application was not running. So I logged off and restarted the computer. That solved the window issue but now atom will not open when I click the icon in the applications folder?

I also tried to put “atom --safe” in the terminal command line but it just said command can not be found?

any help with this would be greatly appreciated


#2

When Atom is working, you can select Install Shell Commands in the menu bar.

As for the issue, does deleting the .atom folder in your home directory help? It will be hidden, so you might need cmd-shift-. to show it.


#3

it does have the option for shell commands, and yes I did get up and running again just had to fully shut down the computer. thanks for the help