Atom 1.3.2 freezing on Mac OS X El Capitan when clicking on search results


#1

Hi,

I’m using Atom 1.3.2 on my MacBook Pro running El Capitan (Mac OS X 10.11.2). It freezes sometimes when I click on one of the search’s results. It doesn’t happen every time, but frequently enough to be annoying. I need to kill the process and restart it again.

I have those community packages installed, in case it helps:

  • autoclose-html
  • color-picker
  • ex-mode
  • fonts
  • markdown-pdf
  • markdown-toc
  • merge-conflicts
  • symbol-gen
  • symbols-tree-view
  • vim-mode

When it freezes, I try to close the app normally, and I get the message that a script is busy, and I can wait for it to finish or close the app. If I decide to wait, it does nothing, and I have to kill the app, at the end.

Any clues?


#2

Have you tried reproducing the issue in Safe Mode?

To launch Safe Mode:

  1. Completely exit all instances of Atom
  2. Launch Atom with the command atom --safe

#3

I’ve also been experiencing this issue. It happens most frequently when I’m attempting to open files with the fuzzy finder, or from a result of a find-in-project search. I’ve also experienced it occasionally when opening files from the tree that are ‘hidden’.

If I had to theorize, I would say that there is some kind of cache atom has been keeping since I updated to the last version, which, as it’s grown, has been moving towards some kind of unstable condition. Total conjecture on my part, though.

I’ll try the safe mode thing, however the issue is difficult to reproduce, because it happens somewhat unpredictably. I just brought it up to a co-worker who uses atom, and is experiencing similar issues. We are both on El Capitan as well.


#4

@ironyinabox: +1. My experience is exactly as you said

@leedohm: using safe mode. Not happening. But as @ironyinabox says, it’s hard to reproduce. It happens every now and then. Couldn’t identify a pattern yet.


#5

If you can reproduce it in Safe Mode, that would be ideal. Since many folks have never encountered this issue, it is quite likely that it is caused by a package you have installed.


#6

Atom on MAC 10.11.2 completly freezes. Atom Helper consuming all the RAM. Back to normal when i kill the process


#7

Can you give us more information? What kind of project are you opening? Have you been just killing Atom over and over and over? Which version of Atom are you using? The more information you can give, the more likely we can help.


#8

Hi, thanks for the reply,
OS 10.11.2
ATOM 1.4.0

While working, Atom Helper consumes more and more RAM. Killing the process at some point releases up to 4Gb RAM.
I have the most popular extensions running.


#9

Have you tried reproducing this issue in Safe Mode?

To launch Safe Mode:

  1. Completely exit all instances of Atom
  2. Launch Atom with the command atom --safe

#10

I frequently have this happen as well. It seems in my case that it will happen when I:

  1. Do a project wide search (cmd + shift + F) and search for something
  2. Open a result before the search has finished.

The only way to fix it is to kill the editor.

I’ll kill the editor, open it up, try the exact same search and it will open the file fine…

Again, it’s very hard to replicate this issue :-/