Atom 1.28.0 won't start without running as admin


#1

Hi guys,

Since past few days, my Atom won’t start unless I run it as admin. By won’t start I mean… it shows up Atom window (refer screenshot below) for 1 or 2 seconds then disappears. I’m using windows 10 x64 and I didn’t change any of its settings or install any new program before this happens.

Any possible cause to this?


Atom can't start after a fresh install
#2

Go to your user folder, find the folder called .atom, and rename it. Then open Atom normally and see if it works.


#4

Still no luck. I’ve also tried reinstalling Atom. I forgot to add that sometimes it shows below error message

atom-error

Here’s some data from Windows Event Viewer, if it helps

Log Name:      Application
Source:        Application Error
Date:          24/6/2018 1:05:04 AM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      workstation
Description:
Faulting application name: atom.exe, version: 1.28.0.0, time stamp: 0x5b2bcb2a
Faulting module name: ntdll.dll, version: 10.0.17134.112, time stamp: 0x6529f37c
Exception code: 0xc0000374
Fault offset: 0x00000000000f4d1b
Faulting process id: 0xbb0
Faulting application start time: 0x01d40b14527e8729
Faulting application path: C:\Users\john\AppData\Local\atom\app-1.28.0\atom.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report Id: b32454f5-2e3c-4c87-9c1e-0673339a9b4d
Faulting package full name: 
Faulting package-relative application ID: 
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2018-06-23T17:05:04.680241600Z" />
    <EventRecordID>6477</EventRecordID>
    <Channel>Application</Channel>
    <Computer>workstation</Computer>
    <Security />
  </System>
  <EventData>
    <Data>atom.exe</Data>
    <Data>1.28.0.0</Data>
    <Data>5b2bcb2a</Data>
    <Data>ntdll.dll</Data>
    <Data>10.0.17134.112</Data>
    <Data>6529f37c</Data>
    <Data>c0000374</Data>
    <Data>00000000000f4d1b</Data>
    <Data>bb0</Data>
    <Data>01d40b14527e8729</Data>
    <Data>C:\Users\john\AppData\Local\atom\app-1.28.0\atom.exe</Data>
    <Data>C:\WINDOWS\SYSTEM32\ntdll.dll</Data>
    <Data>b32454f5-2e3c-4c87-9c1e-0673339a9b4d</Data>
    <Data>
    </Data>
    <Data>
    </Data>
  </EventData>
</Event>

#5

I haven’t seen anything like that in the couple of years I’ve been hanging around this forum.

What happens if you install Atom in portable mode? Just grab either atom-x64-windows.zip or atom-windows.zip according to your computer and unzip it.


#6

Hurm it still won’t run. It’s just weird… other programs work fine. I also ran memcheck and everything seems fine.


#7

It works fine if I boot windows in safe mode.


#8

Further observation shows that this only happen with Atom 1.28.0. Tried with 1.27.2 and 1.27.1 they both work fine.


#9

All very weird. I suggest installing 1.27.2 in portable mode and dropping in to the main Atom repo to make an issue. You should link to this thread and copy all of the relevant information. One of the devs may know enough to help you.