Atom 1.28.0 crashes on macOS when using a proxy


#1

I am using Mac os version of 10.13.5. I have used Atom as my text editor for almost 3 years and it was fine. But recently the Atom could not open, It will not responding for a while and crashed. When I choose reopen it crash again and again. I have tried either delete the ~/.atom directory or the hole app and reinstall it. But it still crash. What’s wrong with it? Can I still use it as my editor or I need to replace one.

Here are some informations:

➔ apm --version

apm 1.19.0
npm 3.10.10
node 6.9.5 x64
atom 1.28.0
python 2.7.10
git 2.13.0

➔ atom --version
Atom : 1.28.0
Electron: 2.0.3
Chrome : 61.0.3163.100
Node : 8.9.3


Atom crash just open all the time
ATOM automatically closes when I open the network
#2

https://github.com/atom/atom/issues/17020 I have found this. It is the same as mine problem. When use Shadowsocks Atom crashed.


#3

I am also finding that Atom is now crashing upon launch.

atom 1.28.0

mac 10.10.5

Dyld Error Message:
Symbol not found: _CIDetectorTypeText
Referenced from: /Applications/Atom.app/Contents/MacOS/…/Frameworks/Electron Framework.framework/Electron Framework
Expected in: /System/Library/Frameworks/QuartzCore.framework/Versions/A/QuartzCore
in /Applications/Atom.app/Contents/MacOS/…/Frameworks/Electron Framework.framework/Electron Framework


#4

Any ideas? I’ve tried uninstalling and reinstalling, but it’s basically unusable now…


#5

@wtlucky sorry yes, that’s the issue where the problem with proxies and Atom 1.28.0 is being tracked. You can install 1.27.2 as described here for now /cc https://github.com/atom/atom/issues/17565#issuecomment-399740133.

@dmtruong you’re hitting the issue described here:

You can subscribe to the mentioned issue for updates but we’re recommending people install 1.27.2, see the same comment mentioned above /cc https://github.com/atom/atom/issues/17565#issuecomment-399740133.


#6

@rsese Do you mean the Atom 1.27.2 doesn’t have the problem with proxies? My situation is not the same as @dmtruong.


#7

Yes, that’s we found in:

Sorry, I thought that was the issue you were pointing to which is similar but was a problem for some people who updated to Atom 1.25 from 1.24. https://github.com/atom/atom/issues/17557 is for people who are using a proxy but Atom started crashing after updating from 1.27 to 1.28.0.

Have you tried 1.27.2?

My situation is not the same as @dmtruong.

Yes, they’re running into the issue I pointed to for them.


#8

See David’s comment here /cc https://github.com/atom/atom/issues/17557#issuecomment-404968140 - 1.28.2 and 1.29.0-beta2 hotfix releases are now available. For folks who had issues with proxies on Atom 1.28 can you give one of these releases a try?