Atom 1.12.0 is getting stuck in macOS Sierra


#1

Hi All,
I have updated Atom to the newest version(1.12) and now it is getting stuck while i doing any work. Specially in typing. It takes two three second to show the letters i am typing and very lagging in response.
I have restart Atom and my mac book pro several times but no luck.
What is going on with this new version update, is it issue in my mac something else. I need to resolve this ASAP because i can’t do anything in my Atom.

Following are my macBook pro spec:
macOS sierrra
16 GB RAM


#2

Due to this issue i reverted back to 1.11.1 version which is more stable than newest version for me.


#3

Have you followed the suggestions in the Debugging document? Also, have you tried running Atom in Safe Mode? To launch Safe Mode:

  1. Completely exit all instances of Atom
  2. Launch Atom with the command atom --safe

Many of the maintainers are running Atom on macOS Sierra and we haven’t seen this problem.


#4

Hi @leedohm
I have tried that. but it doesn’t provide any features I wanted .
When I save a file it shows this lagging issue. After saving it’s shows this lagging. I tried Atom beta even. It shows the same issue


#5

If the problem doesn’t reproduce in Safe Mode, then the slowdown is almost certainly being caused by a community package you have installed. If the slowdown is being caused by a community package, the only way to get it fixed is to determine which package that is. You can do that by either following the instructions in the Flight Manual section on Using Safe Mode or some people have reported good results with using the package-cop package.


#6

It happen for specific file. that file contain 662 line. And when I open this file in console it shows this message
> Handling of ‘mousewheel’ input event was delayed for 1162 ms due to main thread being busy. Consider marking event handler as ‘passive’ to make the page more responive.

Also when I try to save or type it show this lagging issue


#7

It sounds like a package you installed is hooking those input events and doing significant work that is slowing things down. If you could tell us what packages you have installed and as much information you can share about the file (the number of lines doesn’t tell us much), perhaps we can narrow it down more.


#8

This is happening for me as well. Freezes every second making it unusable. I haven’t downloaded any packages so it’s just an issue with Atom. Please help!