Atom 0.85.0 failed to "Quit"


#1

Update to 0.85.0 today and found that it fails to quit (via menu Atom>Quit).
No such issue in previous version.


#2

Duplicate of this most likely?


#3

Different behaviour here:
(1) if atom is launched via command line as using below alias, it fails to quit (no pop-up)

ATOM_PATH=/Users/Shared/Applications/Atom.app
alias atom=${ATOM_PATH}/Contents/Resources/app/atom.sh

(2) if it is open from Finder, Quit works properly.


#4

Tried to reproduce this locally with v0.85.0, but everything is working as expected here.

Try disabling all non-bundled packages (most easily accomplished by renaming ~/.atom/packages) and see if the problem persists.


#5

Same issue here, just upgraded from .84, can’t kill atom from console as the pid changes.

solution:
use keyboard shortcut cmd+q
or
force quit in activity manager


#6

have tried to disable all local packages and it gives same result.

btw, when it was failed to quit, it consumed 100% cpu time.


#7

more observation:

  1. launch atom (and a editor window (untitled of previous document) appear)
  2. close the window (press the red button)
  3. then atom app would be failed to Quit

if, however, just launch atom without close the editor window, you could Quit atom (no matter it was launched via Finder or command line)

c if u could reproduce it.


#8

I can confirm the issue. Can’t quit it after starting from Finder nor from Alfred. The red button, the quit menu and cmd + q don’t do it.


#9

Clicking the red button isn’t supposed to quit the application. It is only supposed to close the window. Many Mac applications behave this way. In fact, it is the default behavior. Applications have to go out of their way to quit when the last window is closed.


#10

I’m also having this issue consistently on a couple of different machines, having to force quit the application to finally get rid of it. Once or twice I have had the “not responding” dialog, but usually not. One time I noticed the application was consuming 100% cpu, but I dont usually check. Tonight I had a crash when attempting to quit: https://gist.github.com/gfarron/10556989


#11

sorry that I should have mentioned in step 3 as:
3. then quit atom app from menu “Atom>Quit” and it failed.


#12

Hi,
I have the same issue.


#13

I’ve encountered the same issue, but it’s intermittent.


#14

I encountered this issue. When trying to quit from the dock, it refuses to quit and memory usage keeps on increasing till all the memory on the machine is used. Ultimately, the process has to be killed.


#15

It also fails to quit on OSX Logout - at which point, all processes should respond to signals regardless of how they were launched.


#16

I just updated to .85 and when I try to quit (right-click and then quit) on Mavericks 10.9.2, it hangs and CPU goes up to 110% and the fan starts revving

I have to kill it manually because it never quits :frowning:

HELP PLZ!


#17

Same here. Pretty often, 0.85 fails to quit and goes to 100% cpu, and memory use keeps growing. Have to force quit it.

EDIT: looks OK in 0.89.


#18

I have the same issue. When opening atom from the terminal I can’t quit afterwards. Plus memory and cpu consumption grows huge eventually.
Osx 10.8


#19

Exactly the same for me, also on 10.8.5.

Opened from terminal. Wont quit, activity monitor registers ~100 CPU and rising mem consumption.


#20

tested 0.89.0 today and the issue is fixed. thx