Atom 0.129.0 fails to install Atom-beautify (NPM Error)


#1
    Installing package atom-beautify failed Error: Installing “atom-beautify@0.11.1” failed.
  at /Applications/Atom.app/Contents/Resources/app/node_modules/settings-view/lib/package-manager.js:242:21
  at exit (/Applications/Atom.app/Contents/Resources/app/node_modules/settings-view/lib/package-manager.js:37:16)
  at BufferedProcess.triggerExitCallback (/Applications/Atom.app/Contents/Resources/app/src/buffered-process.js:49:47)
  at /Applications/Atom.app/Contents/Resources/app/src/buffered-process.js:63:18
  at Socket.<anonymous> (/Applications/Atom.app/Contents/Resources/app/src/buffered-process.js:102:18)
  at Socket.EventEmitter.emit (events.js:129:20)
  at Pipe.close (net.js:461:12)
 

npm ERR! git clone git://github.com/ariya/esprima.git Cloning into bare repository '/Users/razvanz/.atom/.node-gyp/.atom/.apm/_git-remotes/git-github-com-ariya-esprima-git-9077e517'...
npm ERR! git clone git://github.com/ariya/esprima.git fatal: unable to connect to github.com:
npm ERR! git clone git://github.com/ariya/esprima.git github.com[0: 192.30.252.128]: errno=Connection refused
npm http GET https://registry.npmjs.org/underscore

npm http 304 https://registry.npmjs.org/underscore
npm http 304 https://registry.npmjs.org/underscore.string
npm http 304 https://registry.npmjs.org/ast-types
npm ERR! Error: ENOENT, lstat '/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/analytics-node/node_modules/superagent-proxy/node_modules/proxy-agent/node_modules/pac-proxy-agent/node_modules/pac-resolver/node_modules/regenerator/lib/hoist.js'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/npm/npm/issues>

npm ERR! System Darwin 13.3.0
npm ERR! command "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/bin/node" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/bin/npm-cli.js" "--globalconfig" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/.apmrc" "--userconfig" "/Users/razvanz/.atom/.apmrc" "install" "/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/d-114817-9954-rscgic/package.tgz" "--target=0.16.0" "--arch=x64"
npm ERR! cwd /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9
npm ERR! node -v v0.10.30
npm ERR! npm -v 1.4.4
npm ERR! path /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/analytics-node/node_modules/superagent-proxy/node_modules/proxy-agent/node_modules/pac-proxy-agent/node_modules/pac-resolver/node_modules/regenerator/lib/hoist.js
npm ERR! fstream_path /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/analytics-node/node_modules/superagent-proxy/node_modules/proxy-agent/node_modules/pac-proxy-agent/node_modules/pac-resolver/node_modules/regenerator/lib/hoist.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm http GET https://registry.npmjs.org/xregexp/2.0.0
npm http 304 https://registry.npmjs.org/escodegen
npm http 304 https://registry.npmjs.org/underscore
npm ERR! Error: ENOENT, lstat '/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/analytics-node/node_modules/superagent-proxy/node_modules/proxy-agent/node_modules/pac-proxy-agent/node_modules/get-uri/node_modules/readable-stream/lib/_stream_writable.js'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/npm/npm/issues>

npm ERR! System Darwin 13.3.0
npm ERR! command "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/bin/node" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/bin/npm-cli.js" "--globalconfig" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/.apmrc" "--userconfig" "/Users/razvanz/.atom/.apmrc" "install" "/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/d-114817-9954-rscgic/package.tgz" "--target=0.16.0" "--arch=x64"
npm ERR! cwd /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9
npm ERR! node -v v0.10.30
npm ERR! npm -v 1.4.4
npm ERR! path /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/analytics-node/node_modules/superagent-proxy/node_modules/proxy-agent/node_modules/pac-proxy-agent/node_modules/get-uri/node_modules/readable-stream/lib/_stream_writable.js
npm ERR! fstream_path /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/analytics-node/node_modules/superagent-proxy/node_modules/proxy-agent/node_modules/pac-proxy-agent/node_modules/get-uri/node_modules/readable-stream/lib/_stream_writable.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm http 304 https://registry.npmjs.org/xregexp/2.0.0
npm ERR! error rolling back Error: ENOTEMPTY, rmdir '/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/analytics-node/node_modules/superagent-proxy/node_modules/proxy-agent/node_modules/pac-proxy-agent/node_modules/get-uri/node_modules/ftp/node_modules/xregexp'
npm ERR! error rolling back  superagent-proxy@0.3.1 { [Error: ENOTEMPTY, rmdir '/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/analytics-node/node_modules/superagent-proxy/node_modules/proxy-agent/node_modules/pac-proxy-agent/node_modules/get-uri/node_modules/ftp/node_modules/xregexp']
npm ERR! error rolling back   errno: 53,
npm ERR! error rolling back   code: 'ENOTEMPTY',
npm ERR! error rolling back   path: '/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/analytics-node/node_modules/superagent-proxy/node_modules/proxy-agent/node_modules/pac-proxy-agent/node_modules/get-uri/node_modules/ftp/node_modules/xregexp' }
npm ERR! EEXIST, mkdir '/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/analytics-node/node_modules/superagent-proxy/node_modules/proxy-agent/node_modules/pac-proxy-agent/node_modules/get-uri/node_modules/ftp/node_modules/readable-stream'
File exists: /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/analytics-node/node_modules/superagent-proxy/node_modules/proxy-agent/node_modules/pac-proxy-agent/node_modules/get-uri/node_modules/ftp/node_modules/readable-stream
Move it away, and try again. 

npm ERR! System Darwin 13.3.0
npm ERR! command "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/bin/node" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/bin/npm-cli.js" "--globalconfig" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/.apmrc" "--userconfig" "/Users/razvanz/.atom/.apmrc" "install" "/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/d-114817-9954-rscgic/package.tgz" "--target=0.16.0" "--arch=x64"
npm ERR! cwd /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9
npm ERR! node -v v0.10.30
npm ERR! npm -v 1.4.4
npm ERR! path /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/analytics-node/node_modules/superagent-proxy/node_modules/proxy-agent/node_modules/pac-proxy-agent/node_modules/get-uri/node_modules/ftp/node_modules/readable-stream
npm ERR! fstream_path /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/analytics-node/node_modules/superagent-proxy/node_modules/proxy-agent/node_modules/pac-proxy-agent/node_modules/get-uri/node_modules/ftp/node_modules/readable-stream/LICENSE
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code EEXIST
npm ERR! errno 47
npm ERR! fstream_stack /Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/node_modules/fstream/lib/writer.js:171:23

npm ERR! fstream_stack /Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/node_modules/mkdirp/index.js:37:53
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! error rolling back Error: ENOTEMPTY, rmdir '/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/coffee-formatter/node_modules/lazy/test'
npm ERR! error rolling back  atom-beautify@0.11.1 { [Error: ENOTEMPTY, rmdir '/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/coffee-formatter/node_modules/lazy/test']
npm ERR! error rolling back   errno: 53,
npm ERR! error rolling back   code: 'ENOTEMPTY',
npm ERR! error rolling back   path: '/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/coffee-formatter/node_modules/lazy/test' }
npm ERR! Error: Command failed: Cloning into bare repository '/Users/razvanz/.atom/.node-gyp/.atom/.apm/_git-remotes/git-github-com-ariya-esprima-git-9077e517'...
npm ERR! fatal: unable to connect to github.com:
npm ERR! github.com[0: 192.30.252.128]: errno=Connection refused
npm ERR! 
npm ERR! 
npm ERR!     at ChildProcess.exithandler (child_process.js:648:15)
npm ERR!     at ChildProcess.emit (events.js:98:17)
npm ERR!     at maybeClose (child_process.js:756:16)
npm ERR!     at Socket.<anonymous> (child_process.js:969:11)
npm ERR!     at Socket.emit (events.js:95:17)
npm ERR!     at Pipe.close (net.js:465:12)
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/npm/npm/issues>

npm ERR! System Darwin 13.3.0
npm ERR! command "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/bin/node" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/bin/npm-cli.js" "--globalconfig" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/.apmrc" "--userconfig" "/Users/razvanz/.atom/.apmrc" "install" "/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/d-114817-9954-rscgic/package.tgz" "--target=0.16.0" "--arch=x64"
npm ERR! cwd /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9
npm ERR! node -v v0.10.30
npm ERR! npm -v 1.4.4
npm ERR! code 128
npm ERR! Error: ENOENT, lstat '/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/coffee-formatter/node_modules/optimist/readme.markdown'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/npm/npm/issues>

npm ERR! System Darwin 13.3.0
npm ERR! command "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/bin/node" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/bin/npm-cli.js" "--globalconfig" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/.apmrc" "--userconfig" "/Users/razvanz/.atom/.apmrc" "install" "/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/d-114817-9954-rscgic/package.tgz" "--target=0.16.0" "--arch=x64"
npm ERR! cwd /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9
npm ERR! node -v v0.10.30
npm ERR! npm -v 1.4.4
npm ERR! path /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/coffee-formatter/node_modules/optimist/readme.markdown
npm ERR! fstream_path /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/coffee-formatter/node_modules/optimist/readme.markdown
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/emissary/node_modules/underscore-plus/node_modules/underscore/underscore.js'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/npm/npm/issues>

npm ERR! System Darwin 13.3.0
npm ERR! command "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/bin/node" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/bin/npm-cli.js" "--globalconfig" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/.apmrc" "--userconfig" "/Users/razvanz/.atom/.apmrc" "install" "/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/d-114817-9954-rscgic/package.tgz" "--target=0.16.0" "--arch=x64"
npm ERR! cwd /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9
npm ERR! node -v v0.10.30
npm ERR! npm -v 1.4.4
npm ERR! path /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/emissary/node_modules/underscore-plus/node_modules/underscore/underscore.js
npm ERR! fstream_path /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/emissary/node_modules/underscore-plus/node_modules/underscore/underscore.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/js-yaml/node_modules/argparse/node_modules/underscore.string/test/run-qunit.js'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/npm/npm/issues>

npm ERR! System Darwin 13.3.0
npm ERR! command "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/bin/node" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/bin/npm-cli.js" "--globalconfig" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/.apmrc" "--userconfig" "/Users/razvanz/.atom/.apmrc" "install" "/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/d-114817-9954-rscgic/package.tgz" "--target=0.16.0" "--arch=x64"
npm ERR! cwd /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9
npm ERR! node -v v0.10.30
npm ERR! npm -v 1.4.4
npm ERR! path /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/js-yaml/node_modules/argparse/node_modules/underscore.string/test/run-qunit.js
npm ERR! fstream_path /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/js-yaml/node_modules/argparse/node_modules/underscore.string/test/run-qunit.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/lodash/dist/lodash.underscore.js'

npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/npm/npm/issues>

npm ERR! System Darwin 13.3.0
npm ERR! command "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/bin/node" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/bin/npm-cli.js" "--globalconfig" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/.apmrc" "--userconfig" "/Users/razvanz/.atom/.apmrc" "install" "/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/d-114817-9954-rscgic/package.tgz" "--target=0.16.0" "--arch=x64"
npm ERR! cwd /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9
npm ERR! node -v v0.10.30
npm ERR! npm -v 1.4.4
npm ERR! path /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/lodash/dist/lodash.underscore.js
npm ERR! fstream_path /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/lodash/dist/lodash.underscore.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/js-yaml/node_modules/argparse/node_modules/underscore/index.html'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/npm/npm/issues>

npm ERR! System Darwin 13.3.0
npm ERR! command "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/bin/node" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/bin/npm-cli.js" "--globalconfig" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/.apmrc" "--userconfig" "/Users/razvanz/.atom/.apmrc" "install" "/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/d-114817-9954-rscgic/package.tgz" "--target=0.16.0" "--arch=x64"
npm ERR! cwd /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9
npm ERR! node -v v0.10.30
npm ERR! npm -v 1.4.4
npm ERR! path /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/js-yaml/node_modules/argparse/node_modules/underscore/index.html
npm ERR! fstream_path /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/js-yaml/node_modules/argparse/node_modules/underscore/index.html
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/analytics-node/node_modules/superagent-proxy/node_modules/proxy-agent/node_modules/pac-proxy-agent/node_modules/get-uri/node_modules/ftp/node_modules/xregexp/xregexp-all.js'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/npm/npm/issues>

npm ERR! System Darwin 13.3.0
npm ERR! command "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/bin/node" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/bin/npm-cli.js" "--globalconfig" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/.apmrc" "--userconfig" "/Users/razvanz/.atom/.apmrc" "install" "/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/d-114817-9954-rscgic/package.tgz" "--target=0.16.0" "--arch=x64"
npm ERR! cwd /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9
npm ERR! node -v v0.10.30
npm ERR! npm -v 1.4.4
npm ERR! path /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/analytics-node/node_modules/superagent-proxy/node_modules/proxy-agent/node_modules/pac-proxy-agent/node_modules/get-uri/node_modules/ftp/node_modules/xregexp/xregexp-all.js
npm ERR! fstream_path /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/analytics-node/node_modules/superagent-proxy/node_modules/proxy-agent/node_modules/pac-proxy-agent/node_modules/get-uri/node_modules/ftp/node_modules/xregexp/xregexp-all.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/prettydiff/cm/codemirror.js'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/npm/npm/issues>

npm ERR! System Darwin 13.3.0
npm ERR! command "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/bin/node" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/bin/npm-cli.js" "--globalconfig" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/.apmrc" "--userconfig" "/Users/razvanz/.atom/.apmrc" "install" "/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/d-114817-9954-rscgic/package.tgz" "--target=0.16.0" "--arch=x64"
npm ERR! cwd /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9
npm ERR! node -v v0.10.30
npm ERR! npm -v 1.4.4
npm ERR! path /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/prettydiff/cm/codemirror.js
npm ERR! fstream_path /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/prettydiff/cm/codemirror.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat '/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/js-yaml/node_modules/esprima/test/test.js'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/npm/npm/issues>

npm ERR! System Darwin 13.3.0

npm ERR! command "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/bin/node" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/bin/npm-cli.js" "--globalconfig" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/.apmrc" "--userconfig" "/Users/razvanz/.atom/.apmrc" "install" "/private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/d-114817-9954-rscgic/package.tgz" "--target=0.16.0" "--arch=x64"
npm ERR! cwd /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9
npm ERR! node -v v0.10.30
npm ERR! npm -v 1.4.4
npm ERR! path /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/js-yaml/node_modules/esprima/test/test.js
npm ERR! fstream_path /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/node_modules/atom-beautify/node_modules/js-yaml/node_modules/esprima/test/test.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack /Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /private/var/folders/75/7z9wmbln5z7b5cp41hb3qd3w0000gn/T/apm-install-dir-114817-9954-1ee4ag9/npm-debug.log
npm ERR! not ok code 0

#2

Looks like a network error, have you tried to install it a second time?


#3

I was thinking the same. I tried few times during 4-5 hours but I get the same Error.

It is fetching the first packages though. I omitted them in the stack trace to reduce the length. This is where it fails.


#4

Are you able to install or update any other packages?

Also, do you have any way of checking the quality of your internet connection? Is it a bit shaky maybe?


#5

Does git clone git://github.com/ariya/esprima.git fails when executed alone?


#6

Yes, I successfully installed other packages.

My internet connection is fast and stable. It’s very unlikely that it’s the cause.

No. It is successful.

razvanz:Git repositories razvanz$ git clone git://github.com/ariya/esprima.git
Cloning into ‘esprima’…
remote: Counting objects: 5490, done.
remote: Total 5490 (delta 0), reused 0 (delta 0)
Receiving objects: 100% (5490/5490), 20.80 MiB | 3.66 MiB/s, done.
Resolving deltas: 100% (3300/3300), done.
Checking connectivity… done.
razvanz:Git repositories razvanz$


#7

Ok, sounds like an issue on that package’s repository is needed, for the author to look into.

Edit:
For reference though, I had no problem installing it just now (via Settings View):

Have you tried both, apm and settings view?


#8

I dit try both apm and settings view. They are returning the same error.


#9

ehm… err… What about proxies? Is your network behind some weird proxy or firewall setup? Can you try from a different internet connection?


#10

Yes, I am behind a firewall here. I will give it another try when I get home.
I also experienced some errors with bower today. It’s just freezing during bower install.


#11

Thanks @batjko for the ideea.

Telling git to use https solved the problem.

git config --global url."https://".insteadOf git://