Apm won't take my token


#1

Subject pretty much says it all. I’m set up on a new pc, apm works, but when I try to publish it keeps asking for my token over and over. I’ve tried regenerating the token.

$ apm publish --tag 0.1.1
Welcome to Atom!

Before you can publish packages, you'll need an API token.

Visit your account page on Atom.io https://atom.io/account,
copy the token and paste it below when prompted.

Press [Enter] to open your account page on Atom.io. 
Token> <redacted>
Saving token to Keychain ✓
Publishing search-all-keybindings@0.1.1 Welcome to Atom!

Before you can publish packages, you'll need an API token.

on and on and on ...

Ubuntu 14.04.2 LTS
atom 188
apm 0.149.0
npm 2.5.1
node 0.10.35
python 2.7.6
git 1.9.1


#2

Have you tried apm login first?


#3

It does the same thing


#4

Is this the first time you’ve tried publishing something on your Chromebook?


#5

Yes. Although ubuntu so far as handled all other sw correctly. And apm does everything else ok. For example, if I do a apm starred, it asks for my token and when I give it, everything works. It just doesn’t remember the token.

I’m new to linux so I have no doubt I’m doing something wrong. I just have no idea what it could be. Maybe it’s a “keyring” thing, whatever that is. I’ll google to see if I can turn off the keyring.


#6

When I brought up a desktop and a terminal inside the desktop everything worked. It asked me for my keyring password when I did that. So apparently using the ubuntu command line doesn’t work with the keyring. That sucks.

I wonder why an app like apm, meant to be used on the command line, would go to the trouble to use a keyring. I don’t understand that. It appears that apm assumes it is only being used on a desktop. Maybe I’ll post an issue.

I guess I’ll be doing a lot of googling. Sorry for the trouble.

P.S. At least it had nothing to do with my precious chromebook. (grin)


#7

Apm issue: https://github.com/atom/apm/issues/335


#8

Because an app like apm is built as a utility for an app like Atom which is designed for a desktop environment. If you want to improve node-keytar to not use gnome-keyring when the daemon is not available/running, I’m sure such a PR would be accepted.
https://github.com/atom/node-keytar.


#9

I get it now. I didn’t think of that since I’m running Atom in an X window without a desktop.

Trust me, you don’t want my code in core authorization stuff.

FYI to any lurkers: my problem was that I was not exporting the shell variable ATOM_ACCESS_TOKEN. See https://github.com/atom/apm/issues/335.