APM update fails with gyp error


#1

I tried running amp update at home with 0.90 It worked fine at work with same version. I get the following output:

gyp info it worked if it ends with ok
gyp info using node-gyp@0.12.2  
gyp info using node@0.10.26 | darwin | x64
gyp http GET https://gh-contractor-zcbenz.s3.amazonaws.com/atom-shell/dist/v0.11.10/node-v0.11.10.tar.gz
gyp http 200 https://gh-contractor-zcbenz.s3.amazonaws.com/atom-shell/dist/v0.11.10/node-v0.11.10.tar.gz
gyp ERR! UNCAUGHT EXCEPTION 
gyp ERR! stack Error: EPERM, utime '/Users/stevel/.atom/.node-gyp/.node-gyp/0.11.10'
gyp ERR! System Darwin 13.1.0
gyp ERR! command "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/bin/node" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/node-gyp/bin/node-gyp.js" "install" "--target=0.11.10" "--dist-url=https://gh-contractor-zcbenz.s3.amazonaws.com/atom-shell/dist" "--arch=x64"
gyp ERR! cwd /Users/stevel/.atom
gyp ERR! node -v v0.10.26
gyp ERR! node-gyp -v v0.12.2
gyp ERR! This is a bug in `node-gyp`.
gyp ERR! Try to update node-gyp and file an Issue if it does not help:
gyp ERR!     <https://github.com/TooTallNate/node-gyp/issues>

I tried updating node-gyp, and this seemed successful. But this error persists.


Atom install on arch failed
#2

Try to delete ~/.atom/.node-gyp - this is what helped me to get the same issue solved (and what was suggested by atom-support).


#3

Thanks. Now, I get a different error though:

stevel$ apm update
Installing modules ✗

npm ERR! install Couldn't read dependencies
npm ERR! package.json ENOENT, open '/Users/stevel/package.json'
npm ERR! package.json This is most likely not a problem with npm itself.
npm ERR! package.json npm can't find a package.json file in your current directory.

npm ERR! System Darwin 13.1.0
npm ERR! command "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/bin/node" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/bin/npm-cli.js" "--userconfig" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/.apmrc" "install" "--target=0.11.10" "--arch=x64"
npm ERR! cwd /Users/stevel/.atom
npm ERR! node -v v0.10.26
npm ERR! npm -v 1.4.4
npm ERR! path /Users/stevel/package.json
npm ERR! code ENOPACKAGEJSON
npm ERR! errno 34
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /Users/stevel/.atom/npm-debug.log
npm ERR! not ok code 0


#4

What are you trying to achieve? Are you trying to get the latest version of your Atom packages? If so, you should be using apm upgrade.


#5

Thanks, “upgrade” seems to be correct. They mentioned “apm update” in the release notes for 0.90 so i was erroneously using that.