Apm update error

I’m getting an error when I try to update with apm.

$ apm update

Installing modules ✗

npm ERR! install Couldn't read dependencies
npm ERR! package.json ENOENT, open '/Users/josh/package.json'
npm ERR! package.json This is most likely not a problem with npm itself.
npm ERR! package.json npm can't find a package.json file in your current directory.

npm ERR! System Darwin 13.1.0
npm ERR! command "/usr/local/Cellar/node/0.10.26/bin/node" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/bin/npm-cli.js" "--userconfig" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/.apmrc" "install" "--target=0.11.10" "--arch=x64"
npm ERR! cwd /Users/josh
npm ERR! node -v v0.10.26
npm ERR! npm -v 1.4.4
npm ERR! path /Users/josh/package.json
npm ERR! errno 34
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /Users/josh/npm-debug.log
npm ERR! not ok code 0

Does anyone know how to fix this?

1 Like

Potentially a duplicate of: Apm/npm issue installing packages


1 Like

None of those methods are working for me. apm install <package_name> works fine for me, it’s just apm update that’s not working.

I’m having this same issue, here’s what happens when I run apm update:

gyp info it worked if it ends with ok
gyp info using node-gyp@0.12.2
gyp info using node@0.10.26 | darwin | x64
gyp http GET https://gh-contractor-zcbenz.s3.amazonaws.com/atom-shell/dist/v0.11.10/node-v0.11.10.tar.gz
gyp http 200 https://gh-contractor-zcbenz.s3.amazonaws.com/atom-shell/dist/v0.11.10/node-v0.11.10.tar.gz
gyp ERR! stack Error: EPERM, utime '/Users/jakemarsh/.atom/.node-gyp/.node-gyp/0.11.10'
gyp ERR! System Darwin 13.1.0
gyp ERR! command "/Users/jakemarsh/.nvm/v0.10.26/bin/node" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/node-gyp/bin/node-gyp.js" "install" "--target=0.11.10" "--dist-url=https://gh-contractor-zcbenz.s3.amazonaws.com/atom-shell/dist" "--arch=x64"
gyp ERR! cwd /Users/jakemarsh/.atom
gyp ERR! node -v v0.10.26
gyp ERR! node-gyp -v v0.12.2
gyp ERR! This is a bug in `node-gyp`.
gyp ERR! Try to update node-gyp and file an Issue if it does not help:
gyp ERR!     <https://github.com/TooTallNate/node-gyp/issues>


Nope, the issue you mention was fixed in 0.62 while the issue in this topic still exists.

@jakemarsh Here is a solution for the EPERM issue: Can't install or update packages

I still have this problem as well. I take it no one has figured this one out yet?

What are you trying to use apm update for?

Looking at the debug spew from the first post, it looks like they executed the command in their home directory. To my understanding, apm update is specifically for packages that have Node library dependencies … and if you are a package author, you execute it in the root directory of the package for which you want dependencies updated.

If you are trying to get the latest version of your packages, you should be using apm upgrade.


I think you’re right, I just ran apm upgrade and it did what I expected apm update to do. So apm update is for updating the dependencies of your own package?

Yes, that is my understanding. apm install, when executed in the root directory of a package, installs the dependencies of that package. The help for apm update says it just does an apm clean and apm install, which a blank apm install only makes sense in the above situation. That’s when I noticed that apm upgrade also has a -l parameter which lists the packages that are out-of-date … further cementing my theory about the difference between the two commands.

I just had the same problem. I expected apm update to do what apm upgrade does. Some clarification in apm --help would be nice.

one command to update all out-of-date plugins