`apm test` crashes


#1

When I try to run apm test I get unfocused from terminal and I see that new Atom window is being created but it closes immediately after which I go back to terminal and see this message:

2014-08-29 14:40:59.113 Atom[91175:507] Could not get code signature for running application, application updates are disabled: Error Domain=NSOSStatusErrorDomain Code=-67062 "The operation couldn’t be completed. (OSStatus error -67062.)"
[91177:0829/144059:INFO:renderer_main.cc(227)] Renderer process started
[91175:0829/144100:INFO:CONSOLE(92)] "Download the React DevTools for a better development experience: http://fb.me/react-devtools", source: /Applications/Atom.app/Contents/Resources/app/node_modules/react-atom-fork/lib/React.js (92)


Finished in 0 seconds
0 tests, 0 assertions, 0 failures, 0 skipped

Tests passed

#2

Could you give the following information?

  • Which version of Atom are you using?
  • What OS and version are you running?

#3

I built it from source, Version 0.125.0-7f2d998 (0.125.0-7f2d998) and I’m on OSX 10.9.4.


#4

Are you running apm test in a package directory? Or where?


#5

I was running it from directory in which I have few packages, I thought it will run them all. Now I tried running it from package directory and it’s the same. The good thing, though, is that now tests are actually run so summary is not all zeros.


#6

Yeah, apm test isn’t valid outside of a package directory or maybe the Atom source directory itself (not sure, I haven’t used it for that). And yes, I was going to say it doesn’t appear to be a crash because it actually completes. This appears to be completely normal behavior. I just ran it on one of my packages and things worked exactly the same.


#7

OK, so I can use it like this?
Though it’s annoying to have to switch to terminal again after each apm test.


#8

Yes, you can use it like this. I typically run my tests through the Application: Run Package Specs command in the UI, though.