Apm publishing error: `Invalid character in header content ["authorization"]`

Hello, I’m very new to using both Atom and GitHub, but I tried following all the instructions in the flight manual to publish a new syntax package.

when I do
cd github\paradox-ck3-syntax
amp publish paradox-ck3-syntax

I get the error
Invalid character in header content [“authorization”]

I’m using Git Bash on Windows 10, and the repo for the syntax is public. I’ve also linked my account on GitHub to Atom.

The first time I ran the command it asked me for an authenticaion key from Atom which I copy and pasted in, but I had the page open in two tabs at the same time and I don’t know if the key generated a new one each time. So it’s possible the first authentication failed, but now it no longer asks for authenticaion it just throws this error.

I saw another discussion on here where the person had a similar issue and resolved it by running
amp unpublish [package-name]

but when I tried that I just get the same error.

Any help would be appreciated… I feel like i’ve irrevocably broken something because of that authenticaion thing, but the error makes no sense to me :s

Okay I managed to undo the bad authentication key by deleting the credential in the Windows Credential manager.

and then it turned out that my package.json file was pointing to https://github.com/atom/paradox-ck3-syntax.git instead of https://github.com/Seraaron/paradox-ck3-syntax.git

updating the package on Git and reauthenticating correctly fixed the issue