Apm/npm issue installing packages


I ran into an issue, which was not present some hours before.

I noticed that I’m not able anymore to install packages (e.g. apm install emmet). It seems like npm is not accepting self-signed certificates anymore and I wasn’t able to solve it.

Also noted on the npm-blog:

Updating my local npm version does not help either, apm still seems to use 1.3.18

Any ideas, how to solve that?

Thanks a lot!

Sorry, can paste the error code or any images in here due to “new user restriction”

Apm update error
Apm install error

I have the same issue. Sorry for creating a duplicate:


I ran into the same issue too.

After hacking around Atom.app, I was able to find the npm Atom is using and update it to 1.4.4.

$ cd /Applications/Atom.app/Contents/Resources/app/node_modules/atom-package-manager/
$ npm install npm@latest

I was able to install packages after a few more tries. I’m sure the Atom team will fix this problem and update Atom tomorrow. For the meanwhile, you guys can give this a try.


Thanks @adrianlee44. Worked like a charm.


I did not have success in updating NPM, but I’ve been able to install packages by using HTTP instead of HTTPS for the NPM registry when installing Atom packages from the CLI:

npm_config_registry="http://registry.npmjs.org" apm install <package>

This seems to work well, and the configuration change propagates properly to the NPM that Atom is using.

Can't install or update packages

I’d like to second @adrianlee44’s suggestion, with one additional caveat: Make sure you’re using node 0.10.x, or apm will break in colorful and unexpected ways. This bit me when using nvm with node 0.11 as default.


How do we go about getting fixes like this back into mainline Atom? Do the core devs monitor here?


I don’t think there is a way currently as Atom and APM are both private Github repos. A lot of people were running into this problem and tweeting about it so I’m sure the core devs have some ideas.


If you update to the latest version, it’s working fine now :smile:

Restart Atom and it loads the update in the background. After some minutes, there is a menu option under Atom in you Mac app bar, to install and restart.

apm should be at 0.17.0 after this and using the latest npm…


Keep getting the following error after trying to install/update a package:

gyp info it worked if it ends with ok
gyp info using node-gyp@0.12.2
gyp info using node@0.11.10 | darwin | x64
gyp http GET https://gh-contractor-zcbenz.s3.amazonaws.com/atom-shell/dist/v0.11.10/node-v0.11.10.tar.gz
gyp http 200 https://gh-contractor-zcbenz.s3.amazonaws.com/atom-shell/dist/v0.11.10/node-v0.11.10.tar.gz
gyp ERR! stack Error: EPERM, utime '~/.atom/.node-gyp/.node-gyp/0.11.10'
gyp ERR! System Darwin 13.1.0
gyp ERR! command "/Applications/Atom.app/Contents/Frameworks/Atom Helper.app/Contents/MacOS/Atom Helper" "/Applications/Atom.app/Contents/Resources/app/node_modules/atom-package-manager/node_modules/node-gyp/bin/node-gyp.js" "install" "--target=0.11.10" "--dist-url=https://gh-contractor-zcbenz.s3.amazonaws.com/atom-shell/dist" "--arch=x64"
gyp ERR! cwd ~/.atom
gyp ERR! node -v v0.11.10
gyp ERR! node-gyp -v v0.12.2
gyp ERR! This is a bug in `node-gyp`.
gyp ERR! Try to update node-gyp and file an Issue if it does not help:
gyp ERR!     <https://github.com/TooTallNate/node-gyp/issues>

My settings:

apm  0.24.0
npm  1.4.4
node 0.10.26

Vote to close a topic

@rafaelrinaldi Here is a solution for the EPERM issue: Can't install or update packages


Thanks man! Will give it a try.


works like a charm, thanks!


Updating the .apmrc file in resources\app\apm\node_modules\atom-package-manager solved the issue for me.

I included the line
strict-ssl = false

See more details below


@githubjay07 Changing the file you mentioned isn’t recommended, since that is part of the application code of Atom. If you read the information you linked to, it states that you can configure apm using the ~/.atom/.apmrc file. This is where you should put such configuration settings.