Apm not being added to path (Windows 8.1)


#1

I am having issues installing Atom on a Surface Pro 3 with Windows 8.1.

It installs and adds the shortcuts, but there is an issue with adding Atom and npm to the path.

Everything I see says to add C:\Users\USERNAME\AppData\Local\atom\bin to the path, but in my install, that location doesn’t even exist. I tried to add C:\Users\USERNAME\AppData\Local\atom\app-1.0.2\resources\cli to the path which has apm.sh, atom.cmd, atom.js, and atom.sh but it still tells me apm is not found on the path.

Anyone know what the issue could be? I’ve tried re-installing a few times but I haven’t had any success.


#2

So this should indeed be the folder where Atom and apm executables are installed:

If that’s not the case after you install (presumably with the Windows installer?), then that’s an issue which you might want to open on the repo.
There was one open for a similar issue before, but I can’t search for it right now.


#3

I would remove that addition you made to your path.
After each new update you will have to edit your path each time to point to the new location:
C:\Users\USERNAME\AppData\Local\atom\app-1.0.2\resources\cli
The bolded figures will need to reflect the new install each time.

If you can’t get the atom.cmd and apm.cmd files to be installed by redoing the install, you could simply create the C:\Users\USERNAME\AppData\Local\atom\bin folder yourself and add the files manually.
atom.cmd is just:

@echo off
"%~dp0\..\app-1.0.2\resources\cli\atom.cmd" %*

and the apm.cmd is:

@echo off
"%~dp0\..\app-1.0.2\resources\app\apm\bin\apm.cmd" %*

#4

If the bin folder is indeed missing, there may be some wider issue with the installation, though. Even if manually adding these files works.

If I remember correctly, this has happened for some people who had Atom installed via Chocolatey in the past (which kept messing stuff up).