Apm install puts nothing in packages folder


#1

I just installed Atom (never used it). I can’t search for packages as I get the tunnelling error. But I know I can use the apm command line to install.

If I run amp install linter it says it is installing, I get no errors and it gives me a fresh prompt. But the packages are not installed. Nothing appears in my D:/Users//.atom/packages folder.

I am on Windows behind a corporate proxy. I have set my .amprc with the proxy settings needed.

While I’d like to be able to install from the GUI I don’t mind using apm but even that isn’t working and no error message to say why not.

Any ideas?


#2

Do you have the same issue with any packages or just linter?


#3

Yeh, I tried language-terraform too. Same thing.


#4

Is there any extra information if you use the verbose flag?

apm install language-terraform --verbose

#5

Thanks for your reply. I’m afraid there’s no other information with --verbose.

I’ve decided to forget Atom because of this and I am going to use VSC instead.


#6

Hmm, I wonder what the issue was - I’m guessing it’s related to the proxy? I wonder if you would have the same error connecting from a different network. In any case though, I’m sorry the package install experience wasn’t great, if you give Atom another try feel free to reach out again.