Apm install does not check the version of atom


#1

I’m developing on Atom 0.124 and I tried to install the linter package. https://atom.io/packages/linter, both from the UI and using apm install. In both cases it installed version 0.7.3 which depends on Atom > 0.132 https://github.com/AtomLinter/Linter/blob/master/package.json which put me in an inconsistent state.


#2

Newer versions of apm do, but not the one packaged with v0.124.0.

The pull request where it was implemented is here: