Apm hangs everytime I try to install Hydrogen


#1

Running MacOS 10.13.4,
apm 1.19.0
npm 3.10.10
node 6.9.5 x64
atom 1.27.0
python 2.7.15
git 2.14.3

apm hangs every time when I try to install Hydrogen, and only Hydrogen. the process is created but it never finish. Does not consume any CPU, just hang. I cleared my .atom folder and the issue presists.

Any help would be appricated.


#2

Have you tried installing it from the command line, or just from inside Atom?


#3

Yep, tried them both, none worked


#5

You only have trouble with Hydrogen, other packages install ok? I’ll try to install Hydrogen on my computer (on macOS 10.12.6) and see if I run into any issues.


#6

It only occured when I try to install Hydrogen. I assume it’s because the cache file is corrupt but Since there’s no log output, I can’t verify. Also seems like reinstalling Atom didn’t do a thing. So curious


#7

Finally had a chance to give it a try and though it does seem to take a while, it eventually finished and errored out (I didn’t look at any prerequisites to install, I was just trying to see if it did anything at all).

Go ahead try installing with the verbose flag and see if there’s any output?

apm install hydrogen --verbose