Apm doesn't seem to be working in atom 1.3.3


#1

When trying to publish a update apm doesn’t seem to work, but yesterday worked fine before the update. as you can see https://github.com/Skript-Atom/Language-Skript/releases


#2

Have you tried to do apm --help to see if it is just a case of apm not being in your PATH?


#3

Nothing comes up


#4

The system cannot find the path specified

Can you try adding atom folder to the path environment ?
In your case
C:\Users\Admin\AppData\Local\atom\bin


#5

When i tried using “git-bash” it seemed like it kept looking for v1,3.1 folders


#6

On my work computer, APM isn’t in the path.
At home, it works.
The fact that I am not admin at work (only if I log in as such explicitly) might explain that. Another failure of Atom installer on Windows… I understand it tries to be friendly by not asking admin rights when installing, which is nice (we have awful / long login names / passwords) but it should warn about having apm not available out of the box…


#7

I Ended up fixing it by going in to
"C:\Users\USERNAME\AppData\Local\atom\bin" and editing every file, inside the file change “1.3.1” to “1.3.3”