`apm disable` doesn't work on my machine


#1

I’ve previously messed with my config.cson file programmatically (possible cause) but I tried removing the file so that it refreshed to its initial state and I was still unable to disable packages.

The command shows output as if the package has been disabled but it isn’t disabled.


[DELETE] Apm disable/enable packages without adding version number?
#2

What version of Atom are you running (atom -v) and what operating system? Has this been a problem for a while or just recently with a particular version of Atom?

And just to clarify, does disabling from the settings UI work and it’s just apm disable on the command line that doesn’t work for you?


#3

@rsese UI works. apm disable does not.

I’m using brew cask to install atom. I did manually tinker with the config in the past as well.

Tried starting fresh, without success:

$ brew cask uninstall atom
$ mv ~/.atom ~/Desktop

I then installed the latest version from the atom website. Still doesn’t work!

I’m running the latest version of macOS (10.13.5) and latest version of Atom (1.28.2).


#4

Ahhh yeah I can reproduce with Atom 1.30.0-dev-4a5ac6623 on macOS 10.12.6.

I’ll go ahead and open an issue for this.

Thanks for the heads up :+1:


#5

Hmm but it works for you on 1.28.2? @Aerijo said that apm disable worked for him, so I assumed it’s system specific?

I would love to open the issue myself (as practice) if you can provide some more detail on how you’re confirming this isn’t specific to my system.


#6

Hmm but it works for you on 1.28.2?

No, doesn’t work for me with 1.28.2 but did see that it worked in 1.28.1 so looks like a regression.

@Aerijo said that apm disable worked for him, so I assumed it’s system specific?

Oh that’s interesting, was that in 1.28.2 as well?


#7

I would love to open the issue myself (as practice) if you can provide some more detail on how you’re confirming this isn’t specific to my system.

Sounds good :+1:, if you could link it back here after you create it that would be great.

I had asked the other maintainers to give it a try as well and someone else could reproduce with a nightly release (1.30.0-nightly6), so it’s definitely not just your computer.


#8

Here’s where @Aerijo and I previously discussed this issue, but I suppose I should’ve been more clear about what he needed to test.

I’ll open an issue and post it here shortly, thanks!


#9

I thought so… but clearly not. Turns out I must have tried in 1.29.0-beta2 (which works), and just now with 1.28.2 it failed.


#10

Ah ok thanks for clarifying!


#11

Maybe try the beta too? At least to help diagnose this issue. It installs separately to the stable release (though beta seems pretty stable in my opinion). It should work.


#12

Oh ok that’s interesting - so looks like it doesn’t work in 1.28.2, works in 1.29.0-beta2, but doesn’t work on 1.30 (on master/nightly).

If you could put all this information in the issue you open @JBallin that would be great :+1:


#13

Tagged you both on the issue, thanks for your help! Exciting to contribute!


#14

Upon further review, the break was caused by Atom.
The latest change to APM was on 1/3 and Atom worked fine up until 1.28.2 came out on 7/13.

re-opened here: