Apm command never works


#1

Ever since I’ve been using Atom, I’ve never had the apm command work properly. I build Atom locally, with no custom changes made to the source. I use the sudo script/grunt install command to install the apm & atom commands to /usr/local/bin/ each time I make a new build. Atom commands work fine. Each time I install those commands, the apm is always a broken symlink, and I’m unable to follow it to the original file. If I cd into /usr/local/bin/ and run ./apm, I get an error stating too many levels of symbolic links.

I have Atom built into a custom build dir, which is /opt/Atom/. I’ve never really cared about apm not working until now–as I’m trying to publish a syntax theme but I need apm working in order to do so.

I’m on Atom version v0.171.0 currently–but this has been happening since at least v0.125.0 (maybe earlier). I’m running it on Linux Mint 17.


#2

What is the symbolic link pointing to? Run ls -l /usr/local/bin/apm. It will show something like]

lrwxrwxrwx 1 root root 53 Jan 15 21:09 /usr/bin/apm -> ../share/atom/resources/app/apm/node_modules/.bin/apm

where /usr/bin/apm points to /usr/share/atom/resources/app/apm/node_modules/.bin/apm


#3

I’d love to give you that info, but in a flurry of trialing and erroring, I seem to have deleted apm from /usr/local/bin/. :expressionless:

Even after re-running the install command and building Atom from scratch, etc.–the apm command isn’t being placed in /usr/local/bin/ at all now. It’s no where to be found. I didn’t mess with anything else.

Edit: I should note that the atom command is still working fine, and being place appropriately. The build command is creating a new file and everything.


#4

On my machine it is at /usr/bin/atom. Could you check there?

Also try installing atom from the official .deb installer. Does that work?


#5

Installing the deb fixed it. I guess I’ll stop building from source.


#6

Good to hear you fixed it! Maybe the right course of action would be to file a bug at the atom repository that there might be issues witht the building process?


#7

Eh. It is more than likely something wrong on my end–otherwise, I feel that someone else would have reported it before I did.

Quick question: how do you get updates to atom if I installed if via the .deb? I would assume apt-get update, but I’m not getting the latest (0.175.0) via that method.


#8

I haven’t gotten 175 on windows either. I often see a lengthy delay.


#9

As far as I know, Atom isn’t in the apt repositories yet, at least not on Debian. You’ll have to download the .deb for each release. Please correct me if I’m wrong.


#10

Good day.

Install Atom version 1.16.0 and I have problems when I go to cmd when I enter apm help install, the console tells me the following “apm is not recognized as internal or external command, program or batch executable”, I have looked at several Forums but I have not been able to solve.

Windows 7 operating system
thanks for your help

thanks for your help


#11

Your user PATH should include an entry that reads C:\Users\diego.beltran.ga\AppData\Local\atom\bin.


#12

Good afternoon DamnedScholar, thank you very much for your answer, in the path that you indicated to me I have no “bin” folder, I started to search and access the following path "AppData \ Local \ atom \ app-1.16.0 \ resources \ App \ Apm \ bin "

Happy day


#13

Please click on the link I provided for a description of how to locate your PATH environment variable, and check to see if that folder is listed there.