Anyone experiencing "apm update" timeout?


#1

I’ve been getting a ETIMEDOUT error since yesterday. I am sure it’s not a proxy issue as I am connected directly to the internet and I’ve tried computers both at home and in my office.

$ apm upgrade Request for package information failed: connect ETIMEDOUT

I am in Melbourne Australia and I can’t seem to find anyone else that has the problem. I have done a basically verbose log analysis and I think it’s because one or two API call does not return any value in time.

Thanks in advance!


#2

Yes, I do.

$ apm update
Request for package information failed: connect ETIMEDOUT


#3

I think it’s something related to the fact that I am in Australia, I tried to VPN to another country and all seemed to be working.


#4

I’m seeing exactly the same problem from Australia only. When I switch to a full tunnel VPN to US the update completes as normal.


#5

+1. I’m seeing the same problem, and I’m also in Melbourne, Australia. But, when I connect via my employers VPN, updates work fine.

I wonder if this is related to Bigpond. I’m on Bigpond cable broadband, and have been experiencing problems recently that appear related to Bigpond’s DNS servers. Are others who are experiencing the problem also connected via Bigpond?


#6

Confirm that I am using Telstra Bigpond ADSL. My DNS is using OpenDNS, so not sure what exactly is the issue.


#7

I’m also using BigPond, and indeed it does appear to be DNS related. Switching to Google DNS solved the issue for me.


#8

Anyone else getting this again. My DNS change seems to have been a false positive as I now routinely cannot update unless VPNed to US


#9

I’m similarly on BigPond Cable using Google DNS and receive the ETIMEDOUT error in Atom updates, but I am able to update using apm update.

I haven’t yet tried using a VPN, but that doesn’t seem like a longterm solution.


#10

Had the same issue, solved it by changing the IP address and the dns (to be obtained automatically ) , I’m not from Australia.