Anyone else having issues with searches?


#1

Once again here I am trying to switch to Atom.
I’m close to have a workable environment but i’ve stumbled into a quite strange issue.

Almost every global search return none to just a few results, for string I know are present in not git ignored locations.

This project is a wordpress multisite network, where the themes folder is the root of the git repo, and within that I have several themes which I develop one at a time, having that theme open in atom. Can this have something to do with it?

I remember this wasn’t an issue when I’ve used Atom before.


#2

Sorry to bump this topic, but anyone figured out how to deal with this problem?


#3

I haven’t had this issue, so there isn’t much I can suggest without a consistent repro. The more details you can give, the better. Can you reproduce this issue on any other project?


#4

Hi Lee,

Actually not only I can replicate in other but in a different machine also.
All it takes is to open the subfolder instead of the root of the git project and search always returns no results.

Not sure what can I try next to debug this.


#5

I can’t replicate this. Here’s what I did:

  1. Selected a project that has a Git repository
  2. Opened a command-line window
  3. Navigated to the root of the project
  4. Changed to a subdirectory one level below the root (spec in this case)
  5. Opened Atom with atom to start Atom with the current directory (projectRoot/spec) being the root directory
  6. Opened Project Find with Shift+Cmd+F
  7. Searched for a string (Logcat in this case)

Expected and Actual: Search returns numerous results

Other things you could include that could help investigation:

  • Which version of Atom are you using?
  • What OS and version are you running?
  • Do you have the Emmet package installed?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?

#6

I tried something similar, except that I attempted to open the folder from within Atom. Same result as @leedohm.


#7

I noticed a search bug today where Atom wouldn’t return results from the second root directory, only from the first one, even when I explicitly selected “Search in Directory” from the context menu when I right-clicked that directory. I think I recall it working once, so it may not be a persistent bug.

Not sure if it’s related.


#8

Multiple-root folders behavior is hit-or-miss right now. The Atom team is working on patching all the myriad packages for multiple-root folders as fast as they can. In other words, I don’t think it is related :grinning:


#9

I think I know what is causing my search issues.
I have a gitignore pattern that includes all theme folders, but then adds back those im interested in. I guess Atom doesn’t cope well with this, and once those folders are ignored they can’t be added back.
Going to run some tests to confirm this.


#10

Confirmed!!
In my case it was the gitignore that was trashing the search feature.


#11

I’m going to close this as fixed then unless there are any objections?


#12

Sure, sorry I would have done that but can’t see that option anywhere.


#13

It’s a moderator-only thing :grinning:


#14

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.