Anyone else experiencing slowdowns on Windows, release 1.12.0?


#1

Just updated to 1.13.0-beta0 today, and ever since, I’ve had a significantly worse experience. Scroll is choppy, typing is not responsive, opening files takes forever, and the program just generally behaves as if my CPU is at 100% load but everything looks normal in the task manager. I don’t have much else to go on other than my own experience, so I’ll avoid putting in an issue for now, but this may be something that merits a hotfix…


#2

Autocompletion and linting is also super slow. Everything is slow, can’t really narrow it down to specific features :frowning:


#3

The actual release I’m using is 1.12.0, my bad. Still, this only started happening after I updated last.


#4

I have the same problem. I am on Windows 10 Insider preview with a german keyboard (i have removed the internaliaziation plugin because it is not needed anymore in 1.12)
.
Even opening Atom in safe mode and disabling all the plugins wont help. Scrolling in Javascript files is slow. When i type something it takes up to a second until it shows up (deleting the same).

Settings pages are scrolling much faster. When i load a javascript file i can see that the highlighting moving forward one line after the other.
Performance in the previous version was better.


#5

Same problem here. Atom is really slow right now.
I’m on Win10


#6

Glad to see I’m not going crazy. Yeah, I tried disabling various packages (I only have four community packages installed), including core packages. No luck.

Yes, I’ve also noticed that settings/config pages, welcome pages, and the directory viewer appear to be unaffected. The problem seems to be the most pronounced in JS files, and gets worse the larger the project is.

Haven’t tested it yet for source files in other languages, but even after disabling the core autocomplete package I didn’t notice any improvement. It’s likely that this problem exists across all files of all types, to various degrees.

Unfortunately, I had to switch to Visual Studio Code to continue working productively on my largest projects, but it’s not my first choice. I’d love these performance issues to be fixed soon so I can return to Atom :smiley:


#7

Also disabled language-javascript to no positive effect, unfortunately…


#8

Hey… I totally believe you folks and feel really bad about this. But I don’t have enough information to act on this yet. The only thing I can think of is this might be related to a version bump of Electron, so we could potentially prioritize upgrading it and let people try that out.

In the meantime, would anyone be willing to open the dev tools and run a CPU profile and do some stuff that’s turning out to be slow? You can then save the profile output and send it to us for inspection and we can see if there’s some terrible edge case getting activated.


#9

Hi,

i tried to make a CPU profile but when i save it the file has zero bytes.
The developer console is very, very laggy, have to wait 10 seconds or so until i can do something the (on an i7 CPU).


#10

I think this is an Electron issue. We’ll work to fix it.


#11

Yup, same issue here. Windows 10 Insiders Preview. Made a CPU profile of dragging a selection around and simple typing, both were slow. How can I get this to you? The upload function here only accepts images.


#12

I’m also getting these issue in 1.12.0 and the latest beta build.

Running Win10 as well.


#13

Is anyone still experiencing this? Please let us know if you are and which version of Atom you’re running.