Anybody working on issue #979?


#1

Is anybody working on issue #979, i.e. the one where minified JavaScript files crash/freeze the editor? The ticket has been locked since last October and no update since then. There are now 11000+ newer issues so I’m afraid this has been forgotten?


Files with long line lengths slow/stall Atom
#2

I can’t answer your question but in my package you shouldn’t get this problem for minified j’s files. I do a check for long lines in my grammar and don’t parse them. In any event, atom won’t allow more than a limited number of scopes per line, so trying to parse a long line with grammar is a bit redundant. You can try my grammar package and see if that helps you, or maybe suggest that the atom js package uses a similar approach and avoid parsing long lines.


#3

It hasn’t been forgotten, no. The solution isn’t simple and will probably require significant changes to Atom’s syntax highlighting engine. Performance is always one of our highest priorities.


#4

I’ve loved Atom… but I can’t work as it keeps crashing on long files. I’ve read about issue #979 opened in 2013 and it matches my symptoms. I have to leave and go to M$ Visual Code whatever. So long Atom, sad to leave you.


#5

Already in 2016, but the problem has not been solved.
I tried ATOM and it was excellent.
But if the problem is unsolvable, the atoms can not be used and it will have to be removed.
Why not just ignore synaxis long lines?


#6

Atom already does this.


#7

Ok. Thank you. How can I enable it?


#8

It’s always on. It just does not seem to be enough to fix the issue.