Any numbers I type in are in black


#1

Any numbers i type in or even the line count numbers are all in dark and is sometimes hard to see the numbers as i have a dark theme. Does anyone know how i could fix this?


How to change number line colour?
Theme Numeric Character Color Issues
#2

I do not know what’s up, but I have a few questions that could help us figure that out.

  1. Please share a screenshot so that we can see it.
  2. Does it happen when you open Atom from the command line with atom --safe?
  3. Do the numbers stay colored if you change your syntax theme?

#3

Hello there. I have started with Atom today. Unfortunately I have the same problem. All kind of numbers are black. I have tried different (syntax) themes already – the letters changed but the numbers stayed the same. So were the line numbers.

Here’s a screenshot:

Hope you can help.
Thanks


#4

The fact that your font is generic serif indicates that you have added a custom font under Settings -> Editor that Atom does not recognize. You should remove that font first and see if that fixes the numbers.


#5

You’re right. Thank you