Am I the only one with cursor position issues?


#1

Hi everyone,

I’m testing Atom for a few days now, and since the beginning and from updates to updates, I still have an issue with the cursor position.

When I start using alt+arrows to navigate between words, the visual cursor position is wrong, randomly displayed 2 or 3 characters before its real place, making the edition of a text really, really painful, since you need to move the cursor blindly, type one char to see if it’s right, etc…

Am I the only one with this issue ?

For information, I use the Source Code Pro font, at size 11.

Thanks in advance,


#2

do you write with languages other than English ? because when I write some Arabic words and get back to English the courser will go bananas.


#3

Nope, but it can be a track to follow too. :slight_smile:


#4

Possible dupe?


#5

I’ve just updated my Source Code Pro fonts, restart everything, and the problem still happens.
A bit less, but still. :frowning:

I will try with another font later in the day, keep you in touch.

(hope it’s not font-related, I’m very used to Source Code and don’t want any other font, as possible)


#6

After some researchs, it appears that I had issues with some fonts installed on my system.

After a system-fonts restoration, an a complete reinstall of Atom, all seems to be fine. :slight_smile:


#7

I’m having the same trouble - cursor isn’t positioned right every now and then. What did you do exactly ? How did you “restore” fonts ?


#8

There’s to process i followed:

  1. In the Font Book app, there’s a link in the bottom of the File menu to restore fonts (I don’t know the name of the entry in english since my system is in french). Select it. It will remove all your fonts, restoring the system’s fonts, and moving the previous fonts in a folder of your library. Reinstall the fonts you want to use.
  2. Clean your font cache (I use Clean My Mac for that, but Onyx, which is free, do it also)
  3. Complete uninstall Atom (I also have used Clean My Mac to remove all the ~/Library folders related to Atom
  4. Reinstall Atom from website
  5. Reinstall your Atom packages
  6. Enjoy :slight_smile:

#9

I experienced the same issue; mine was related to a configuration in my stylesheet. I had added the following selector to my stylesheet to adjust the letter spacing:

   letter-spacing:-0.3px

After removing the selector, the issue was fixed.


#10

I did all the things recommended by leny and am still having the issue. Its a bit different now though. The cursor is almost directly in the middle of the letter now.


#11

I am having this same issue. It’s the only thing about Atom that causes me consistent grief. :smile:

I’m using the following:

  • Atom version 0.103.0
  • Inconsolata at 15pt
  • Atom Dark theme

Restarting Atom temporary solves the issue, but it eventually starts happening again.


#12

+1
me too have this problem when typing arabic.


#13

Same here with:

  • Atom 121
  • Ubuntu 14.04 64b
  • Atom Dark theme

#14

There is an issue open on the repo, regarding weird cursor positions.
have a look at that and see if that is what you’re seeing, then subscribe to it to find out when/how it gets fixed.


#15

I had this too because I added an extra pixel of width to my indent guides by adding a border to it. Atom uses absolute positioning to line up cursors and text, so even a tiny change will mess things up. Also you can’t change the letter-spacing on your font - it has to be 0 or you’ll see issues.


#16

i had the same issue, and i fix it this way:
check your plug-ins and disable one by one, until you find the one who is making you troubles.
When u find the one, you can:

  1. write to that plugin developer, i’m sure he will be interested to fix this issue.
  2. you can bring back the rest of the plug-ins you also disabled.

Cheers! :wink: