Always prompted for passphrase for SSH key


#1

Hi!

I am trying to use an SSH key to authenticate with Bitbucket for my git interactions in atom. I’m not sure if it matters, but I am doing this using the native support for OpenSSH in Windows 10 that was released with the Spring 2018 update. I am able to push and pull successfully, but I am prompted for my passphrase every time, even though I put my identity into ssh-agent. How can I stop atom from prompting me for my passphrase every time?

More details are below:

I created an SSH key (with passphrase), put the public key on my Bitbucket account, and added the identity to my ssh-agent
At this point, I can use the PowerShell prompt to verify that my key has been added:

PS C:\Users\Michael> ssh-add -l
2048 SHA256:[REDACTED]  .\id_rsa (RSA)

I can also verify that ssh-agent is running:

PS C:\Users\Michael> Get-Process ssh-agent

Handles  NPM(K)    PM(K)      WS(K)     CPU(s)     Id  SI ProcessName
-------  ------    -----      -----     ------     --  -- -----------
      0       8      220        292       0.00   5004   2 ssh-agent
     86       7     1276       4424             12484   0 ssh-agent

Furthermore, I can use my key to authenticate with Bitbucket (note that I don’t get prompted for a passphrase):

PS C:\Users\Michael> ssh git@bitbucket.org
PTY allocation request failed on channel 0
logged in as [REDACTED].

You can use git or hg to connect to Bitbucket. Shell access is disabled.
Connection to bitbucket.org closed.

Now, in atom, when I try to fetch or push I get this prompt asking me for my passphrase:
image
When I enter my passphrase, the fetch or push completes successfully. The problem is that every time I try to fetch or push I am prompted for the passphrase. How can I stop getting prompted for my passphrase? Why doesn’t ssh-agent allow me to do that?