AltGr+] doesn't writes ']' and folds lines


#1

Hello,

I have an azerty keyboard on Windows, so to write ‘]’ I have to hit Alt Gr + ].
I tried, but I was surprised that it folds lines instead… so actually, I can’t type ‘]’ :frowning:

I took a look at the key bindings, but didn’t found anything for “alt+]”. There is “ctrl+alt+]” instead. When I try to override it with the action “”, it doesn’t works… (not sure if it’s the right way of disabling a shortcut)


#2

Instead of putting an empty string as the command you should set it to "unset!" to unset the keybinding. There have been other issues with non-US keyboards, though, so it might be that even unsetting the keybinding doesn’t work.


#3

Does someone know if non-US keyboards layout support is coming soon ? It’s really annoying and I think Atom is the only editor I know having this issue. If at least unsetting keybindings was working it’ll be a huge improvement ! :smile:


#4

I just found this package : https://atom.io/packages/keyboard-localization

It works just fine for me, I have an azerty layout on windows too !

Just install it and select your layout in the settings.

:wink: