"Alt-undefined" with removed special symbols in macOS


#1

I’m trying to get my meta/alt keybindings setup in Atom, but Atom does not seem to recognize the keybindings after I’ve removed the symbols from the alt layer (if I ever need to type ‘ƒ’ I’ll switch to a different layout), though they are still not actually blank or dead keys.
I followed one of the guides on http://stackoverflow.com/questions/11876485/how-to-disable-typing-special-characters-when-pressing-option-key-in-mac-os-x, which made reference to http://wordherd.com/keyboards/. This has worked in the past for me with Intellij, but Atom doesn’t seem to cooperate.
When I enable the Key Binding Resolver, it just shows me “alt-unidentified”. I would to use the classic emacs chords, but this is thwarting me. Anyone have any ideas?


#2

See the blog post The Wonderful World of Keyboards for the background story of supporting keyboards on top of Chromium. From what it sounds like, you’ve defined your own keyboard layout that our system doesn’t know about. You may have to create a map that allows Atom to understand that layout. I’m about to head to bed so I’ll see if I can find the documentation around how to do that tomorrow.


#3

The API function that can be used to customize Atom’s keystroke handling is here:

An example of how to use this can be found in the PR introducing it:

https://github.com/atom/atom-keymap/pull/164

I’ll be adding some quick documentation to the Atom Flight Manual around this later today.


#4

Thank you very much! I look forward to the update.


#5

So I was looking into this a bit more and I found this gem: “If the key cannot be identified, the returned value is “Unidentified”.” (https://developer.mozilla.org/en-US/docs/Web/API/KeyboardEvent/key). Does this mean I’m hosed? The keys that I have mapped underneath my alt “layer” are all unicode that don’t have any real character output.


#6

I don’t know … is “Unidentified” what is being returned for keys on your alt layer?


#7

I get “alt-unidentified”. Not uppercase, but it seems pretty damning to me =/