Alt Keybinding is really non productive and interferes with work alot


#1

I have been using atom for about 2 months, before that i was using eclipse, the only problem I have with atom is the mapping of Alt key,
I use keyboard for everything on linux and alt key is pressed numerous times shifting windows using Alt+Tab, or so many other Alt options. And I am sure everyone faces that problem. Since Alt key is mapped to “hide” menu bar it gets really annoying every time I switch windows or tabs it becomes really annoying. Any chance of fixing that permanently or at least provide it in the keybind section where I can unbind it. Right now neither is possible.


#2

add

'atom-workspace':
    'alt': ' '
    'ctrl-alt': ' '

to your keymap.

and / or disable
'Window: Toggle Menu Bar'
via Command Palette.

To do this, open Command Palette (CTRL-SHIFT-P) and type toggle menu bar.


#3

tried doesnt work


#4

Tried, does work for me for years on KDE and Gnome.

(you may want to check the formating in your keymap, whitespace is important)


#5

Perhaps ->

### keymap.cson ###

'*':
  '^alt': ' '

#6

I was using
‘.platform-linux’:

‘alt’: ‘abort:!’

and it was working till Atom 1.24 but since i updated to 1.25 any of those completely disables the menu bar. I don’t want to disable the bar just disable the alt key. I can’t get my head around the fact that alt key is mapped. its like mapping a shift key or ctrl key to a toggle, so everytime you try to type a secondary keyboard character you end up toggling something, or when you try to safe your file you instead toggle some music.


#7

thanks for your help


#8

I always hide the menu bar.
I also have to block ‘ctrl-alt’, otherwise when I hit ctrl first and then alt, the menu bar is back.

Like I said, this:

'atom-workspace':
  'alt': ' '
  'ctrl-alt': ' '

works for me on KDE and Gnome. Always latest version of Atom.

In theory, if I want to have the menu bar always visible, like the OP does,
then I don’t have to add anything to my keymap.

Atom does not always hide the menu bar when you hit ‘alt’.
This is actually a feature that I can turn on and off in the control panel (toggle menu bar).
When enabled, Atom displays a message.

I wonder what Linux Distro and Desktop Environment the OP uses.


#9

Sorry for not detailing, the issue was double, Alt key is map in KDE for menubar display, so I guess its a KDE issue, but all other apps I use don’t have optionof hiding the menubar so the option never did come in play until Atom. For now I disable Atom menubar hiding and things worked fine