Alt-<key> menu-bar interaction overrides shortuts


#1

On Linux, when using Alt- shortcuts and there is a menu item matching the key, the atom shortcut will be ignored and instead the menu bar item would be selected. This looks like a bug or it should be a configurable behavior.

Thanks!


#2

Can you press ctrl-. to see what it is being called at the same time?


#3

It just show ‘alt’ without any keys, so it seems to be native behavior of menubar in Linux. Thus atom (or atom-shell?) probably needs to override that somehow.


#4

I had the opposite problem, the emacs.json settings made my alt-button not operate the menus. The hint from AbeEstrada, above, led me to the fix.

I deleted the file “/usr/local/share/atom/resources/app/keymaps/emacs.json” and problem solved.

So if anyone wants the File, Edit, View menus to work from the keyboard - so one can, for example, press “alt-f” and then “s” to save a file, that fix worked for me (I use “cntl-right-arrow” for ‘next word’, not “alt-f”)


#5

Rather than hacking around inside or deleting Atom default files (like emacs.json), I would recommend anyone interested in this kind of thing file a bug on Atom Core to help figure out a solution that will work for everyone.


#6

Filed: Alt+{letter} menu shortcuts and arrow key navigation don’t work in Windows #4057


#7

Like the original poster freiksenet, I hate the fact that the menu bar swallows useful key mappings like alt-f (forward word) to do something rarely needed like open the file menu.

I searched and searched for ways to disable these alt menu keys and found nothing. Turns out you can kill them off using a bit of script in your init file. I am posting this here so other people can find this solution.

Tested on Ubuntu 15.04 with the Unity desktop. Atom editor version 1.0.

# Get rid of the alt-menu shortcuts
atom.menu.template.forEach (t) ->
  t.label = t.label.replace("&", "")
atom.menu.update()

Override Windows menu hotkeys?
#8

Oh! You’re genius man!

I’ve been stuck in this for two bloody days and you just saved my ass!

I’ve even tried to call atom.menu.remove() to remove all the menu items in file menu, but it still gives me an empty ‘File’ menu :cry:

I’m using Ubuntu 14.10 with Unity desktop, Atom editor version 1.0.19.


#9

I am glad those who do not use this can disable it, but please do not remove it for the rest of us. I use “Cntl - RightArrow” to move a word forward - have for ~20 years. I use “Alt-F-S” to save -and do it all the time to save my work for ~20 years. I am glad to see that Atom is accommodating to how each of us have learned to “play” our keyboards.


#10

After spent my half day searching on this, your answer is the only one works for me. The issue is disabling all those keybinding with ALT in Linux system setting or CCMS somehow doesn’t work for me (ubuntu 16.04). Thank you so much!