All Icons fail to load on startup


#1

When I start Atom, none of the icons are displaying (folder, files, preferences, etc). When I open up the dev console and reload the window, I see requests for the .woff and .woff2 files (octicons, file-icons, etc) have the “canceled” status. If I then go to Preferences -> Themes and change the UI theme to anything, the window reloads again and successfully retrieves the icon files. Any idea what might be causing this?


All icons appear as squares (like symbols do when the correct font is not installed)
All icons appear as squares (like symbols do when the correct font is not installed)
#2

Because I couldn’t post a second image in my initial post:


#3

Looking at the amount of time, it is being canceled because the requests are timing out. Have you tried just deleting the /Applications/Atom.app file and downloading it new?


#4

Yes, and that didn’t solve the issue. The other thing I tried was to delete my entire ~./atom folder. After doing that, the icons successfully loaded after the first time I started Atom, but then after getting everything set up again the issue came back. Given this looks to be a timeout issue, I wonder if I just have too many packages installed? or a particular package is causing this? Are there any additional logs, etc I could provide to support this? Otherwise I might just start uninstalling packages one by one to see if I can find a culprit.


#5

Have you tried replicating the problem in Safe Mode? To launch Safe Mode:

  1. Completely exit all instances of Atom
  2. Launch Atom with the command atom --safe

If you can replicate it in Safe Mode, then it isn’t a problem of too many packages being loaded. (And I honestly doubt that it is too many packages causing the problem because JavaScript is single-threaded.)


#6

Just tried and was not able to replicate this issue in Safe Mode. So I guess that means one of my installed packages is causing this problem? Would it be worthwhile to start disabling them one by one?


#7

Generally, that’s what it means when Safe Mode doesn’t replicate the problem, yes. And yes, I would try disabling them one at a time and restart in between.


#8

So after some experimentation, I’m able to reproduce this by doing the following:

Having only the following community packages installed/enabled:

  • react
  • refactor
  • js-refactor

And then ensure at least one .js / .jsx (as long as the file is using React) tab is opened.

Restarting Atom results in the icons failing to load every time, until I do ONE of the following:

  • Close the file(s) using React before restarting
  • Disable any ONE of the aforementioned packages.

@grotiusc, any chance you are using these same packages?


#9

@seanparmelee Yes, I’m using those three too. Strange enough, this morning Atom started fine, with the icons. I haven’t made any changes so it’s a bit weird.