After upgrading packages today: Error: spawn pycodestyle ENOENT


#1

Noticed there were a few package updates available today. After upgrading I now get a ton of “Error: spawn pycodestyle ENOENT” dialogs containing the same stack trace:

    at exports._errnoException (util.js:1026:11)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:193:32)
    at onErrorNT (internal/child_process.js:359:16)
    at _combinedTickCallback (internal/process/next_tick.js:74:11)
    at process._tickCallback (internal/process/next_tick.js:98:9)```
whenever i open or type in a file.

MacOs Atom 1.13.0

#2

If you have linter-pep8 package installed, run this command in terminal sudo pip install pycodestyle


#3

Worked for me too, thanks!


#4

Thanks that fixed it.


#5

Just a little clarity as to what happened here:

pep8 was renamed to pycodestyle back in June, however a lot of the ecosystem is still catching up to this change.

linter-pep8 finally caught up to this rename with the v2 release, which renamed it to linter-pycodestyle including a change to the default executable to pycodestyle.

Something to watch out for in all of this: Although this should be a seamless update, apparently there is a bug in APM where the old linter-pep8 package isn’t removed when the new linter-pycodestyle was installed, so you will likely need to manually uninstall the old linter-pep8 package or it will always show as having an available update.


#6

I had the same issue on Ubuntu. @Arcanemagus answer is correct the error is caused by package being renamed. Fix that worked for me was

  1. Uninstalling pep8 sudo pip uninstall pep8
  2. Uninstalling pycodestyle sudo pip uninstall pep8
  3. Again installing pycodestyle sudo pip install pep8
  4. Installing ATOM linter for python apm install linter-pycodestyle
  5. Checking if pycodestyle was installed correctly
$ which pycodestyle
/usr/local/bin/pycodestyle